aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/tools/eventsystem/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/imports/tools/eventsystem/CMakeLists.txt')
-rw-r--r--src/imports/tools/eventsystem/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/imports/tools/eventsystem/CMakeLists.txt b/src/imports/tools/eventsystem/CMakeLists.txt
new file mode 100644
index 0000000..719534d
--- /dev/null
+++ b/src/imports/tools/eventsystem/CMakeLists.txt
@@ -0,0 +1,16 @@
+set_source_files_properties(EventSystem.qml
+ PROPERTIES
+ QT_QML_SINGLETON_TYPE true
+)
+
+qt_internal_add_qml_module(QuickStudioEventSystem
+ URI "QtQuick.Studio.EventSystem"
+ VERSION "${PROJECT_VERSION}"
+ DESIGNER_SUPPORTED
+ NO_SYNC_QT
+ PAST_MAJOR_VERSIONS 1
+ QML_FILES
+ EventSystem.qml
+ EventListener.qml
+)
+