summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/windows/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-02-11 20:23:12 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-02-11 20:23:12 +0100
commitc53f8c038c0736aeb208bcd69bf3b5e2816c29ae (patch)
treedb26e488f8d165fa10d2ccd26ec2d029b0088d75 /src/plugins/platforms/windows/CMakeLists.txt
parent9bab556005e4d0475eeaf1b279c1da9ddac398f3 (diff)
parentc9e67a7926c2932217f6d484ea69219d077ef176 (diff)
Merge remote-tracking branch 'origin/dev' into wip/cmake
Diffstat (limited to 'src/plugins/platforms/windows/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/windows/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/plugins/platforms/windows/CMakeLists.txt b/src/plugins/platforms/windows/CMakeLists.txt
index 0481246384..0c903d8757 100644
--- a/src/plugins/platforms/windows/CMakeLists.txt
+++ b/src/plugins/platforms/windows/CMakeLists.txt
@@ -87,6 +87,11 @@ qt_add_resource(QWindowsIntegrationPlugin "openglblacklists"
## Scopes:
#####################################################################
+qt_extend_target(QWindowsIntegrationPlugin CONDITION TARGET Qt::PlatformCompositorSupportPrivate
+ PUBLIC_LIBRARIES
+ Qt::PlatformCompositorSupportPrivate
+)
+
qt_extend_target(QWindowsIntegrationPlugin CONDITION QT_FEATURE_accessibility
SOURCES
uiautomation/qwindowsuiaaccessibility.cpp uiautomation/qwindowsuiaaccessibility.h
@@ -118,7 +123,7 @@ qt_extend_target(QWindowsIntegrationPlugin CONDITION QT_FEATURE_vulkan
Qt::VulkanSupportPrivate
)
-#### Keys ignored in scope 4:.:.:windows.pro:NOT TARGET___equals____ss_QT_DEFAULT_QPA_PLUGIN:
+#### Keys ignored in scope 5:.:.:windows.pro:NOT TARGET___equals____ss_QT_DEFAULT_QPA_PLUGIN:
# PLUGIN_EXTENDS = "-"
qt_extend_target(QWindowsIntegrationPlugin CONDITION QT_FEATURE_opengl AND NOT QT_FEATURE_dynamicgl AND NOT QT_FEATURE_opengles2