aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGatis Paeglis <gatis.paeglis@theqtcompany.com>2015-11-17 14:13:50 +0100
committerGatis Paeglis <gatis.paeglis@theqtcompany.com>2015-12-01 07:25:10 +0000
commit4383f6ec880dc1b2db4760216ea1d1a96fcd9cf2 (patch)
treeac24c791951d6861cb419ab1b02d273d30be6d84
parentaed413df1ee31aad6f67eca405ed01d82d628fc7 (diff)
ostree: Add TLS support
Change-Id: I2cbfe533a8ce58d337f77f013b0da47a6a91681e Reviewed-by: Samuli Piippo <samuli.piippo@theqtcompany.com>
-rw-r--r--recipes/libsoup-2.4/libsoup-2.4_2.46.0.bbappend28
-rw-r--r--recipes/ostree/ostree.bb8
2 files changed, 35 insertions, 1 deletions
diff --git a/recipes/libsoup-2.4/libsoup-2.4_2.46.0.bbappend b/recipes/libsoup-2.4/libsoup-2.4_2.46.0.bbappend
new file mode 100644
index 00000000..bc3d1ffe
--- /dev/null
+++ b/recipes/libsoup-2.4/libsoup-2.4_2.46.0.bbappend
@@ -0,0 +1,28 @@
+#############################################################################
+##
+## Copyright (C) 2015 Digia Plc and/or its subsidiary(-ies).
+##
+## This file is part of the Qt Enterprise Embedded Scripts of the Qt
+## framework.
+##
+## $QT_BEGIN_LICENSE$
+## Commercial License Usage Only
+## Licensees holding valid commercial Qt license agreements with Digia
+## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
+## may use this file in accordance with the terms contained in said license
+## agreement.
+##
+## For further information use the contact form at
+## http://www.qt.io/contact-us.
+##
+##
+## $QT_END_LICENSE$
+##
+#############################################################################
+
+# Remove this recipe when openembedded-core/meta/recipes-support/libsoup/
+# will be updated to 2.50.0 version or above.
+PV = "2.50.0"
+
+SRC_URI[md5sum] = "9a84d66e1b7ccd3bd340574b11eccc15"
+SRC_URI[sha256sum] = "1e01365ac4af3817187ea847f9d3588c27eee01fc519a5a7cb212bb78b0f667b"
diff --git a/recipes/ostree/ostree.bb b/recipes/ostree/ostree.bb
index c4a6f69c..bc13ac2f 100644
--- a/recipes/ostree/ostree.bb
+++ b/recipes/ostree/ostree.bb
@@ -41,7 +41,13 @@ S = "${WORKDIR}/git"
DEPENDS = "glib-2.0 e2fsprogs gpgme attr libsoup-2.4 libgsystem libassuan xz"
RRECOMMENDS_${PN} += "gnupg"
-EXTRA_OECONF = "--with-dracut --without-selinux --without-libarchive --with-grub2=no --enable-gtk-doc-html=no"
+EXTRA_OECONF = "--with-dracut \
+ --without-selinux \
+ --without-libarchive \
+ --with-grub2=no \
+ --enable-gtk-doc-html=no \
+ --with-soup \
+ --enable-libsoup-client-certs"
do_configure_prepend() {
cd ${S}