aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2016-04-11 09:13:23 +0300
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2016-04-12 09:24:26 +0000
commit5a14a092e02921b63c0add8e278089ef96beb314 (patch)
tree1205d8a51535ada20ad20e86071ea7ff7cda8a10
parentd153b85f7c96a1a6a033fc2764efab877e7f9e9d (diff)
gcc: patch already applied on oe layer
Change-Id: I8230869a08fcb902c55b5dfd22e1221c918ce895 Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
-rw-r--r--recipes/gcc/gcc-4.9/0062-gcc-var-tracking.c-backport-from-gcc-trunk-r212178.patch39
-rw-r--r--recipes/gcc/gcc-source_4.9.bbappend26
2 files changed, 0 insertions, 65 deletions
diff --git a/recipes/gcc/gcc-4.9/0062-gcc-var-tracking.c-backport-from-gcc-trunk-r212178.patch b/recipes/gcc/gcc-4.9/0062-gcc-var-tracking.c-backport-from-gcc-trunk-r212178.patch
deleted file mode 100644
index c0ea62f0..00000000
--- a/recipes/gcc/gcc-4.9/0062-gcc-var-tracking.c-backport-from-gcc-trunk-r212178.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From b30ffb8097749fdb55704aa7d8307ca1a58255d6 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Stefan=20M=C3=BCller-Klieser?= <s.mueller-klieser@phytec.de>
-Date: Tue, 7 Apr 2015 16:15:11 +0200
-Subject: [PATCH] gcc/var-tracking.c: backport from gcc trunk r212178
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-resolves a bug seen on cortexa8 building qt5 libraries.
-
-2014-06-30 Joseph Myers <joseph@codesourcery.com>
-
- * var-tracking.c (add_stores): Return instead of asserting if old
- and new values for conditional store are the same.
-
-git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@212178 138bc75d-0d04-0410-961f-82ee72b054a4
-
-Signed-off-by: Stefan Müller-Klieser <s.mueller-klieser@phytec.de>
----
- gcc/var-tracking.c | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/gcc/var-tracking.c b/gcc/var-tracking.c
-index 65d8285..7c38910 100644
---- a/gcc/var-tracking.c
-+++ b/gcc/var-tracking.c
-@@ -5997,7 +5997,8 @@ add_stores (rtx loc, const_rtx expr, void *cuip)
- {
- cselib_val *oval = cselib_lookup (oloc, GET_MODE (oloc), 0, VOIDmode);
-
-- gcc_assert (oval != v);
-+ if (oval == v)
-+ return;
- gcc_assert (REG_P (oloc) || MEM_P (oloc));
-
- if (oval && !cselib_preserved_value_p (oval))
---
-1.9.1
-
diff --git a/recipes/gcc/gcc-source_4.9.bbappend b/recipes/gcc/gcc-source_4.9.bbappend
deleted file mode 100644
index 2b937e66..00000000
--- a/recipes/gcc/gcc-source_4.9.bbappend
+++ /dev/null
@@ -1,26 +0,0 @@
-##############################################################################
-##
-## Copyright (C) 2016 The Qt Company Ltd.
-## Contact: http://www.qt.io/licensing/
-##
-## This file is part of the Boot to Qt meta layer.
-##
-## $QT_BEGIN_LICENSE:COMM$
-##
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see http://www.qt.io/terms-conditions. For further
-## information use the contact form at http://www.qt.io/contact-us.
-##
-## $QT_END_LICENSE$
-##
-##############################################################################
-
-FILESEXTRAPATHS_append := "${THISDIR}/gcc-4.9:"
-
-SRC_URI += " \
- file://0062-gcc-var-tracking.c-backport-from-gcc-trunk-r212178.patch \
- "