aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2016-08-22 10:21:53 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2016-08-22 11:08:38 +0000
commit90bf1f50f69b9cbf0fcc709c53f617e8b68533d0 (patch)
tree651f56702756768a69ae2075b8a5637ecfe44aaa
parent0f967048d5bd99ffacfb9893b76818293aaaa8a0 (diff)
Remove automotive recipes
Automotive was released (and supported) in the jethro Change-Id: Iab8560b4b0d530e872eef585c635b45274a4507b Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
-rw-r--r--conf/distro/b2qt-auto.conf25
-rw-r--r--recipes-qt/automotive/gammaray_git.bb29
-rw-r--r--recipes-qt/automotive/neptune-ui/neptune.service11
-rw-r--r--recipes-qt/automotive/neptune-ui_git.bb62
-rw-r--r--recipes-qt/automotive/qtapplicationmanager_git.bb58
-rw-r--r--recipes-qt/automotive/qtivi_git.bb37
-rw-r--r--recipes-qt/automotive/qtwebbrowser_git.bb40
-rw-r--r--recipes-qt/images/b2qt-automotive-qt5-image.bb50
-rw-r--r--recipes-qt/meta/meta-toolchain-b2qt-automotive-qt5-sdk.bb31
9 files changed, 0 insertions, 343 deletions
diff --git a/conf/distro/b2qt-auto.conf b/conf/distro/b2qt-auto.conf
deleted file mode 100644
index 46d41eb9..00000000
--- a/conf/distro/b2qt-auto.conf
+++ /dev/null
@@ -1,25 +0,0 @@
-##############################################################################
-##
-## Copyright (C) 2016 The Qt Company Ltd.
-## Contact: http://www.qt.io/licensing/
-##
-## This file is part of the Boot to Qt meta layer.
-##
-## $QT_BEGIN_LICENSE:COMM$
-##
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see http://www.qt.io/terms-conditions. For further
-## information use the contact form at http://www.qt.io/contact-us.
-##
-## $QT_END_LICENSE$
-##
-##############################################################################
-
-include conf/distro/b2qt.conf
-
-PREFERRED_VERSION_qtwayland = "5.6%"
-PREFERRED_VERSION_qtwayland-native = "5.6%"
diff --git a/recipes-qt/automotive/gammaray_git.bb b/recipes-qt/automotive/gammaray_git.bb
deleted file mode 100644
index 033e534c..00000000
--- a/recipes-qt/automotive/gammaray_git.bb
+++ /dev/null
@@ -1,29 +0,0 @@
-SUMMARY = "GammaRay Qt introspection probe"
-HOMEPAGE = "http://www.kdab.com/gammaray"
-
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://LICENSE.GPL.txt;md5=5996517d53e3c2722d457fb633e970ed"
-
-inherit cmake_qt5
-
-SRC_URI = "git://github.com/KDAB/GammaRay;branch=${BRANCH}"
-
-BRANCH = "2.4"
-SRCREV = "4995051c9d6733ce3eabb486283160bf31c87c10"
-PV = "2.5.50+git${SRCPV}"
-
-DEPENDS = "qtdeclarative qtlocation qtsvg qttools qtconnectivity"
-
-S = "${WORKDIR}/git"
-
-EXTRA_OECMAKE += " -DGAMMARAY_BUILD_UI=OFF"
-
-FILES_${PN}-dev += " \
- /usr/lib/cmake/* \
- /usr/mkspecs/modules/* \
-"
-FILES_${PN}-dbg += " \
- /usr/lib/.debug/* \
- /usr/lib/gammaray/*/*/.debug \
- /usr/lib/gammaray/*/*/styles/.debug \
-"
diff --git a/recipes-qt/automotive/neptune-ui/neptune.service b/recipes-qt/automotive/neptune-ui/neptune.service
deleted file mode 100644
index 9d7881c4..00000000
--- a/recipes-qt/automotive/neptune-ui/neptune.service
+++ /dev/null
@@ -1,11 +0,0 @@
-[Unit]
-Description=Neptune
-After=systemd-user-sessions.service
-
-[Service]
-ExecStart=/usr/bin/appcontroller /usr/bin/appman -r -c /opt/am/config.yaml -c am-config.yaml --dbus none Main1280x800.qml
-Restart=on-failure
-WorkingDirectory=/opt/neptune
-
-[Install]
-WantedBy=multi-user.target
diff --git a/recipes-qt/automotive/neptune-ui_git.bb b/recipes-qt/automotive/neptune-ui_git.bb
deleted file mode 100644
index 79879584..00000000
--- a/recipes-qt/automotive/neptune-ui_git.bb
+++ /dev/null
@@ -1,62 +0,0 @@
-##############################################################################
-##
-## Copyright (C) 2016 The Qt Company Ltd.
-## Contact: http://www.qt.io/licensing/
-##
-## This file is part of the Boot to Qt meta layer.
-##
-## $QT_BEGIN_LICENSE:COMM$
-##
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see http://www.qt.io/terms-conditions. For further
-## information use the contact form at http://www.qt.io/contact-us.
-##
-## $QT_END_LICENSE$
-##
-##############################################################################
-
-DESCRIPTION = "Neptune IVI UI"
-LICENSE = "GPLv3"
-LIC_FILES_CHKSUM = "file://LICENSE.GPLv3;md5=024d61f4545fb889faa57982553ce094"
-
-inherit qt5-module systemd
-
-SRC_URI = " \
- git://codereview.qt-project.org/qt-apps/neptune-ui;branch=${BRANCH};protocol=http \
- file://neptune.service \
- "
-
-SRCREV = "b3f10d156349727310ec30b27d01e639cce4f570"
-BRANCH = "master"
-
-S = "${WORKDIR}/git"
-
-DEPENDS = "qtbase qtdeclarative"
-RDEPENDS_${PN} = "qtapplicationmanager qtivi qtvirtualkeyboard \
- ${@base_contains('DISTRO_FEATURES', 'webengine', 'qtwebengine', '', d)}"
-
-do_configure_prepend() {
- echo "qml.path = /opt/neptune" >> ${S}/neptuneui.pro
-}
-
-do_install_append() {
- install -m 0755 -d ${D}${systemd_unitdir}/system
- install -m 0644 ${WORKDIR}/neptune.service ${D}${systemd_unitdir}/system/
-
- install -m 0644 ${S}/Main*.qml ${D}/opt/neptune
- install -m 0644 ${S}/am-config.yaml ${D}/opt/neptune
-}
-
-PACKAGES =+ "${PN}-apps"
-RRECOMMENDS_${PN} += "${PN}-apps"
-
-FILES_${PN}-apps += "/opt/neptune/apps"
-FILES_${PN} += "\
- /opt/neptune \
- "
-
-SYSTEMD_SERVICE_${PN} = "neptune.service"
diff --git a/recipes-qt/automotive/qtapplicationmanager_git.bb b/recipes-qt/automotive/qtapplicationmanager_git.bb
deleted file mode 100644
index 502dd061..00000000
--- a/recipes-qt/automotive/qtapplicationmanager_git.bb
+++ /dev/null
@@ -1,58 +0,0 @@
-##############################################################################
-##
-## Copyright (C) 2016 The Qt Company Ltd.
-## Contact: http://www.qt.io/licensing/
-##
-## This file is part of the Boot to Qt meta layer.
-##
-## $QT_BEGIN_LICENSE:COMM$
-##
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see http://www.qt.io/terms-conditions. For further
-## information use the contact form at http://www.qt.io/contact-us.
-##
-## $QT_END_LICENSE$
-##
-##############################################################################
-
-DESCRIPTION = "Qt component for application lifecycle management"
-LICENSE = "GPLv3"
-LIC_FILES_CHKSUM = "file://LICENSE.GPLv3;md5=311507adb75495acc0b61d69109485ce"
-
-inherit qmake5
-
-SRC_URI = " \
- git://codereview.qt-project.org/qt/qtapplicationmanager;branch=${BRANCH};protocol=ssh \
- "
-
-SRCREV = "b7578378b578788c2ae9c60708a2908d3b090c16"
-BRANCH = "dev"
-
-DEPENDS = "qtbase qtdeclarative libyaml libarchive \
- ${@base_contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}"
-
-S = "${WORKDIR}/git"
-
-EXTRA_QMAKEVARS_PRE += "\
- -config force-singleprocess \
- -config enable-dummydata \
- -config enable-ivi-logging \
- -config install-prefix=/usr \
- -config systemd-workaround \
- "
-
-do_install_append() {
- install -m 0755 -d ${D}/opt/am/
- install -m 0644 ${S}/template-opt/am/config.yaml ${D}/opt/am/
-}
-
-FILES_${PN} += "\
- /opt/am \
- ${libdir}/appman \
- ${datadir}/dbus-1"
-FILES_${PN}-dbg += "${libdir}/appman/.debug"
-FILES_${PN}-dev += "${OE_QMAKE_PATH_LIBS}/*.prl"
diff --git a/recipes-qt/automotive/qtivi_git.bb b/recipes-qt/automotive/qtivi_git.bb
deleted file mode 100644
index 038a0c48..00000000
--- a/recipes-qt/automotive/qtivi_git.bb
+++ /dev/null
@@ -1,37 +0,0 @@
-##############################################################################
-##
-## Copyright (C) 2016 The Qt Company Ltd.
-## Contact: http://www.qt.io/licensing/
-##
-## This file is part of the Boot to Qt meta layer.
-##
-## $QT_BEGIN_LICENSE:COMM$
-##
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see http://www.qt.io/terms-conditions. For further
-## information use the contact form at http://www.qt.io/contact-us.
-##
-## $QT_END_LICENSE$
-##
-##############################################################################
-
-DESCRIPTION = "Qt IVI"
-LICENSE = "LGPL-3.0"
-LIC_FILES_CHKSUM = "file://header.LGPL3-PELAGICORE;md5=0f5beb4df202cb6ef5cbc5296f3a3fa4"
-
-inherit qt5-module
-
-SRC_URI = " \
- git://codereview.qt-project.org/qt/qtivi;branch=${BRANCH};protocol=ssh \
- "
-
-SRCREV = "2d378320dc07b8b3ac9a9ce89b7f7a99caa72f8a"
-BRANCH = "dev"
-
-S = "${WORKDIR}/git"
-
-DEPENDS = "qtbase qtdeclarative"
diff --git a/recipes-qt/automotive/qtwebbrowser_git.bb b/recipes-qt/automotive/qtwebbrowser_git.bb
deleted file mode 100644
index 25494bf3..00000000
--- a/recipes-qt/automotive/qtwebbrowser_git.bb
+++ /dev/null
@@ -1,40 +0,0 @@
-##############################################################################
-##
-## Copyright (C) 2016 The Qt Company Ltd.
-## Contact: http://www.qt.io/licensing/
-##
-## This file is part of the Boot to Qt meta layer.
-##
-## $QT_BEGIN_LICENSE:COMM$
-##
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see http://www.qt.io/terms-conditions. For further
-## information use the contact form at http://www.qt.io/contact-us.
-##
-## $QT_END_LICENSE$
-##
-##############################################################################
-
-DESCRIPTION = "Qt Web Browser"
-LICENSE = "GPLv3"
-LIC_FILES_CHKSUM = "file://src/main.cpp;md5=e78c6c33aa5ec2464456b72daf61ef9c;beginline=1;endline=36"
-
-inherit qmake5 sdk-sources
-
-SRC_URI = " \
- git://codereview.qt-project.org/qt-apps/tqtc-qtwebbrowser;branch=${BRANCH};protocol=ssh;sdk-uri=5.6/Src/qtwebbrowser \
- "
-
-SRCREV = "2e18b419a7084b1e39bf8749855768a1002e34de"
-BRANCH = "dev"
-
-S = "${WORKDIR}/git"
-
-DEPENDS = "qtbase qtdeclarative qtwebengine"
-
-FILES_${PN} += "/data/user/qt/qtwebbrowser"
-FILES_${PN}-dbg += "/data/user/qt/qtwebbrowser/.debug"
diff --git a/recipes-qt/images/b2qt-automotive-qt5-image.bb b/recipes-qt/images/b2qt-automotive-qt5-image.bb
deleted file mode 100644
index 004c2e85..00000000
--- a/recipes-qt/images/b2qt-automotive-qt5-image.bb
+++ /dev/null
@@ -1,50 +0,0 @@
-##############################################################################
-##
-## Copyright (C) 2016 The Qt Company Ltd.
-## Contact: http://www.qt.io/licensing/
-##
-## This file is part of the Boot to Qt meta layer.
-##
-## $QT_BEGIN_LICENSE:COMM$
-##
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see http://www.qt.io/terms-conditions. For further
-## information use the contact form at http://www.qt.io/contact-us.
-##
-## $QT_END_LICENSE$
-##
-##############################################################################
-
-DESCRIPTION = "B2Qt Automotive Qt5 image"
-LICENSE = "QtEnterprise"
-LIC_FILES_CHKSUM = "file://${QT_LICENCE};md5=7bc9c54e450006250a60e96604c186c9"
-PR = "r0"
-
-DEPLOY_CONF_TYPE = "Automotive"
-
-IMAGE_FEATURES += "\
- package-management \
- ssh-server-dropbear \
- tools-debug \
- debug-tweaks \
- hwcodecs \
- "
-
-inherit core-image
-inherit bootfs-image
-
-MACHINE_EXTRA_INSTALL_QT ?= ""
-
-IMAGE_INSTALL += "\
- ${MACHINE_EXTRA_INSTALL_QT} \
- packagegroup-b2qt-embedded-base \
- packagegroup-b2qt-embedded-tools \
- ${@base_contains("DISTRO_FEATURES", "gstreamer010", "packagegroup-b2qt-embedded-gstreamer010", "", d)} \
- ${@base_contains("DISTRO_FEATURES", "gstreamer", "packagegroup-b2qt-embedded-gstreamer", "", d)} \
- packagegroup-b2qt-qt5-modules \
- packagegroup-b2qt-automotive-addons \
- "
diff --git a/recipes-qt/meta/meta-toolchain-b2qt-automotive-qt5-sdk.bb b/recipes-qt/meta/meta-toolchain-b2qt-automotive-qt5-sdk.bb
deleted file mode 100644
index 945a3305..00000000
--- a/recipes-qt/meta/meta-toolchain-b2qt-automotive-qt5-sdk.bb
+++ /dev/null
@@ -1,31 +0,0 @@
-##############################################################################
-##
-## Copyright (C) 2016 The Qt Company Ltd.
-## Contact: http://www.qt.io/licensing/
-##
-## This file is part of the Boot to Qt meta layer.
-##
-## $QT_BEGIN_LICENSE:COMM$
-##
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see http://www.qt.io/terms-conditions. For further
-## information use the contact form at http://www.qt.io/contact-us.
-##
-## $QT_END_LICENSE$
-##
-##############################################################################
-
-DESCRIPTION = "B2Qt embedded Qt5 SDK toolchain"
-
-LICENSE = "QtEnterprise"
-LIC_FILES_CHKSUM = "file://${QT_LICENCE};md5=7bc9c54e450006250a60e96604c186c9"
-
-inherit populate_b2qt_qt5_sdk
-
-TOOLCHAIN_HOST_TASK += "nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host"
-TOOLCHAIN_TARGET_TASK += "packagegroup-b2qt-embedded-qt5-toolchain-target \
- packagegroup-b2qt-automotive-qt5-toolchain-target"