aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2016-09-23 09:52:06 +0300
committerMikko Gronoff <mikko.gronoff@qt.io>2016-09-23 09:06:04 +0000
commit92c92eec83fd8c68de419decbe7743b0791dc38c (patch)
tree261529015016aea2fc9f9f870d27e2bbde18bcb9
parent2b115238356e2cfa963f004cb8469533d4d21305 (diff)
Add connman patch to disable connman with boot over nfs
A workaround to avoid connman to bring the boot interface down then up during network boot. Task-number: QTBUG-56051 Change-Id: Ic22fac9cd7e9892439fb462f08313cda4d9da9aa Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r--recipes/connman/connman_%.bbappend24
-rw-r--r--recipes/connman/files/0001-disable-connman-when-booting-over-nfs.patch21
2 files changed, 45 insertions, 0 deletions
diff --git a/recipes/connman/connman_%.bbappend b/recipes/connman/connman_%.bbappend
new file mode 100644
index 00000000..0b03755a
--- /dev/null
+++ b/recipes/connman/connman_%.bbappend
@@ -0,0 +1,24 @@
+##############################################################################
+##
+## Copyright (C) 2016 The Qt Company Ltd.
+## Contact: http://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:COMM$
+##
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see http://www.qt.io/terms-conditions. For further
+## information use the contact form at http://www.qt.io/contact-us.
+##
+## $QT_END_LICENSE$
+##
+##############################################################################
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+SRC_URI += "file://0001-disable-connman-when-booting-over-nfs.patch"
diff --git a/recipes/connman/files/0001-disable-connman-when-booting-over-nfs.patch b/recipes/connman/files/0001-disable-connman-when-booting-over-nfs.patch
new file mode 100644
index 00000000..d45ce18d
--- /dev/null
+++ b/recipes/connman/files/0001-disable-connman-when-booting-over-nfs.patch
@@ -0,0 +1,21 @@
+From a934f6b3ef4c4ff5f36a79d11c9eed59b3ffa9ae Mon Sep 17 00:00:00 2001
+From: Mikko Gronoff <mikko.gronoff@qt.io>
+Date: Tue, 20 Sep 2016 11:02:50 +0300
+Subject: [PATCH] Disable connman when booting over NFS
+
+---
+ src/connman.service.in | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/connman.service.in b/src/connman.service.in
+index 7b6195e..3fc197a 100644
+--- a/src/connman.service.in
++++ b/src/connman.service.in
+@@ -3,6 +3,7 @@ Description=Connection service
+ Requires=dbus.socket
+ After=dbus.socket
+ Before=remote-fs.target
++ConditionKernelCommandLine=!root=/dev/nfs
+
+ [Service]
+ Type=dbus