aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2016-06-02 12:58:54 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2016-06-06 12:21:53 +0000
commitf775774f21c3edbb73e19031d6d38c603f42f16b (patch)
tree5e3482d4b06b3dbfb0bff58e1e6e430fd175f83d
parentab47141905ed04e64160e1c24a9af603e5ecd276 (diff)
qt5: update submodules and meta-qt5
Disable SHA checking for Qt modules, so we can use sha1s from the release branch without breaking build after release. Change-Id: I97b4d29fdbaceea9529fa2550564951f2186435f Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
-rw-r--r--conf/distro/b2qt.conf3
-rw-r--r--recipes-qt/qt5-addons/qtcharts_git.bb2
-rw-r--r--recipes-qt/qt5-addons/qtdatavis3d_git.bb2
-rw-r--r--recipes-qt/qt5-addons/qtdeclarative-render2d_git.bb2
-rw-r--r--recipes-qt/qt5-addons/qtquickcompiler_git.bb2
-rw-r--r--recipes-qt/qt5-addons/qtvirtualkeyboard_git.bb2
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bbappend2
-rw-r--r--recipes-qt/qt5/qt3d_git.bbappend2
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bbappend2
-rw-r--r--recipes-qt/qt5/qtbase_git.bbappend2
-rw-r--r--recipes-qt/qt5/qtcanvas3d_git.bbappend2
-rw-r--r--recipes-qt/qt5/qtconnectivity_git.bbappend2
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bbappend2
-rw-r--r--recipes-qt/qt5/qtgraphicaleffects_git.bbappend2
-rw-r--r--recipes-qt/qt5/qtimageformats_git.bbappend2
-rw-r--r--recipes-qt/qt5/qtlocation_git.bbappend2
-rw-r--r--recipes-qt/qt5/qtmultimedia_git.bbappend2
-rw-r--r--recipes-qt/qt5/qtquickcontrols2_git.bb2
-rw-r--r--recipes-qt/qt5/qtquickcontrols_git.bbappend4
-rw-r--r--recipes-qt/qt5/qtsensors_git.bbappend2
-rw-r--r--recipes-qt/qt5/qtserialbus_git.bb2
-rw-r--r--recipes-qt/qt5/qtserialport_git.bbappend2
-rw-r--r--recipes-qt/qt5/qtsvg_git.bbappend2
-rw-r--r--recipes-qt/qt5/qttools_git.bbappend2
-rw-r--r--recipes-qt/qt5/qttranslations_git.bbappend2
-rw-r--r--recipes-qt/qt5/qtwayland-native_git.bbappend2
-rw-r--r--recipes-qt/qt5/qtwayland_git.bbappend2
-rw-r--r--recipes-qt/qt5/qtwebchannel_git.bbappend2
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bbappend4
-rw-r--r--recipes-qt/qt5/qtwebsockets_git.bbappend2
-rw-r--r--recipes-qt/qt5/qtxmlpatterns_git.bbappend2
-rw-r--r--scripts/manifest.xml2
32 files changed, 37 insertions, 32 deletions
diff --git a/conf/distro/b2qt.conf b/conf/distro/b2qt.conf
index 8b38faaa..946e2385 100644
--- a/conf/distro/b2qt.conf
+++ b/conf/distro/b2qt.conf
@@ -68,6 +68,9 @@ MACHINE_EXTRA_INSTALL_SDK_HOST ?= ""
OE_QMAKE_PLATFORM_NATIVE_mingw32 = "win32-g++-oe"
OE_QMAKE_PLATFORM_mingw32 = "win32-g++-oe"
+# Disable SHA validation for branch
+QT_MODULE_BRANCH = "5.6;nobranch=1"
+
PACKAGE_EXCLUDE_COMPLEMENTARY ?= "qtquickcompiler"
IMAGE_FSTYPES = "tar.gz conf"
diff --git a/recipes-qt/qt5-addons/qtcharts_git.bb b/recipes-qt/qt5-addons/qtcharts_git.bb
index 5e95d149..559beb75 100644
--- a/recipes-qt/qt5-addons/qtcharts_git.bb
+++ b/recipes-qt/qt5-addons/qtcharts_git.bb
@@ -26,6 +26,6 @@ LIC_FILES_CHKSUM = "file://src/charts/qchart.h;md5=a712f087e2146153f45db2e8eb1a3
inherit qt5-module qtquickcompiler
require recipes-qt/qt5/qt5-git.inc
-SRCREV = "f4ba2fb9840279f986bd11ab6860e6a3125d9599"
+SRCREV = "d137ae33ccf01882f80770919b1daa199dec7019"
DEPENDS = "qtbase qtdeclarative qtmultimedia"
diff --git a/recipes-qt/qt5-addons/qtdatavis3d_git.bb b/recipes-qt/qt5-addons/qtdatavis3d_git.bb
index a148bdc2..9b9f239e 100644
--- a/recipes-qt/qt5-addons/qtdatavis3d_git.bb
+++ b/recipes-qt/qt5-addons/qtdatavis3d_git.bb
@@ -26,6 +26,6 @@ LIC_FILES_CHKSUM = "file://src/datavisualization/global/qdatavisualizationglobal
inherit qt5-module
require recipes-qt/qt5/qt5-git.inc
-SRCREV = "4f23f0f984ef2ee96d5baa3a74a465d6734381ba"
+SRCREV = "4d4a9609fab58da304e4c13b9a37531116a4fadb"
DEPENDS += "qtbase qtdeclarative qtmultimedia"
diff --git a/recipes-qt/qt5-addons/qtdeclarative-render2d_git.bb b/recipes-qt/qt5-addons/qtdeclarative-render2d_git.bb
index 51625196..1c45cb85 100644
--- a/recipes-qt/qt5-addons/qtdeclarative-render2d_git.bb
+++ b/recipes-qt/qt5-addons/qtdeclarative-render2d_git.bb
@@ -26,6 +26,6 @@ LIC_FILES_CHKSUM = "file://src/plugins/scenegraph/softwarecontext/softwarelayer.
inherit qt5-module
require recipes-qt/qt5/qt5-git.inc
-SRCREV = "3a22766e8c4ea39836f197552e92b3cc78e77f62"
+SRCREV = "334ca348b0badb284a1ade66b61bdc588da64e33"
DEPENDS = "qtbase qtdeclarative"
diff --git a/recipes-qt/qt5-addons/qtquickcompiler_git.bb b/recipes-qt/qt5-addons/qtquickcompiler_git.bb
index 42013e72..60187706 100644
--- a/recipes-qt/qt5-addons/qtquickcompiler_git.bb
+++ b/recipes-qt/qt5-addons/qtquickcompiler_git.bb
@@ -29,7 +29,7 @@ SRC_URI = " \
git://codereview.qt-project.org/qt/tqtc-qmlcompiler;branch=${BRANCH};protocol=ssh \
"
-SRCREV = "ea222ff87942781d1091fdcd0385a0c842d21e15"
+SRCREV = "a2eac30f3be41447af1c9f2c3f3c841b68ca4d9c"
BRANCH = "5.6"
S = "${WORKDIR}/git"
diff --git a/recipes-qt/qt5-addons/qtvirtualkeyboard_git.bb b/recipes-qt/qt5-addons/qtvirtualkeyboard_git.bb
index f4bdbcc2..85dfcbb9 100644
--- a/recipes-qt/qt5-addons/qtvirtualkeyboard_git.bb
+++ b/recipes-qt/qt5-addons/qtvirtualkeyboard_git.bb
@@ -26,7 +26,7 @@ LIC_FILES_CHKSUM = "file://src/virtualkeyboard/plugin.cpp;md5=8913d0b71519756d2e
inherit qt5-module qtquickcompiler
require recipes-qt/qt5/qt5-git.inc
-SRCREV = "4d480f8f0c1ca3308f4c3a423ad30d5d44e9c1bf"
+SRCREV = "8b75b05f8b515efc6f1a6a40214cf61abc4d8a9f"
DEPENDS = "qtbase qtdeclarative qtsvg hunspell"
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bbappend b/recipes-qt/qt5/nativesdk-qtbase_git.bbappend
index 41922ab4..326bdec7 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bbappend
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bbappend
@@ -19,7 +19,7 @@
##
##############################################################################
-SRCREV = "072f5b513e486e884ea7fa4a1cac9aedf3846374"
+SRCREV = "540978288ea0f6ed0b166bb9207f427a4c825ab6"
FILESEXTRAPATHS_prepend := "${THISDIR}/qtbase:"
diff --git a/recipes-qt/qt5/qt3d_git.bbappend b/recipes-qt/qt5/qt3d_git.bbappend
index b050083f..f7ae8840 100644
--- a/recipes-qt/qt5/qt3d_git.bbappend
+++ b/recipes-qt/qt5/qt3d_git.bbappend
@@ -25,4 +25,4 @@ SRC_URI_append_class-target = " \
file://0001-Remove-qgltf.patch \
"
-SRCREV = "8fb8f65da85e16a3f4d798d2175cec918d2c5afb"
+SRCREV = "2270fae50f8d69858b2df2287342c02a4cd5357c"
diff --git a/recipes-qt/qt5/qtbase-native_git.bbappend b/recipes-qt/qt5/qtbase-native_git.bbappend
index 79e150ed..31cc314d 100644
--- a/recipes-qt/qt5/qtbase-native_git.bbappend
+++ b/recipes-qt/qt5/qtbase-native_git.bbappend
@@ -19,7 +19,7 @@
##
##############################################################################
-SRCREV = "072f5b513e486e884ea7fa4a1cac9aedf3846374"
+SRCREV = "540978288ea0f6ed0b166bb9207f427a4c825ab6"
FILESEXTRAPATHS_prepend := "${THISDIR}/qtbase:"
diff --git a/recipes-qt/qt5/qtbase_git.bbappend b/recipes-qt/qt5/qtbase_git.bbappend
index cc68c72f..e2c41917 100644
--- a/recipes-qt/qt5/qtbase_git.bbappend
+++ b/recipes-qt/qt5/qtbase_git.bbappend
@@ -45,7 +45,7 @@ do_configure_prepend() {
install -m 0644 ${WORKDIR}/oe-device-extra.pri ${S}/mkspecs
}
-SRCREV = "072f5b513e486e884ea7fa4a1cac9aedf3846374"
+SRCREV = "540978288ea0f6ed0b166bb9207f427a4c825ab6"
# Temporarily here, until merged upstream
PACKAGECONFIG[kms] = "-kms,-no-kms,drm virtual/egl"
diff --git a/recipes-qt/qt5/qtcanvas3d_git.bbappend b/recipes-qt/qt5/qtcanvas3d_git.bbappend
index c2ee6e1d..7a161768 100644
--- a/recipes-qt/qt5/qtcanvas3d_git.bbappend
+++ b/recipes-qt/qt5/qtcanvas3d_git.bbappend
@@ -19,4 +19,4 @@
##
##############################################################################
-SRCREV = "791ddce7d41b126ba4744a6701597f49dbf99f3b"
+SRCREV = "72312730a7507f77898df0876b9437c43587e1d1"
diff --git a/recipes-qt/qt5/qtconnectivity_git.bbappend b/recipes-qt/qt5/qtconnectivity_git.bbappend
index f2040ccf..0d15c67d 100644
--- a/recipes-qt/qt5/qtconnectivity_git.bbappend
+++ b/recipes-qt/qt5/qtconnectivity_git.bbappend
@@ -21,4 +21,4 @@
PACKAGECONFIG += "bluez4"
-SRCREV = "dedff12a896d51c469d2af82664b86a10f8fa7fe"
+SRCREV = "7393531856058a8a0fe440d3a64728248958ac81"
diff --git a/recipes-qt/qt5/qtdeclarative_git.bbappend b/recipes-qt/qt5/qtdeclarative_git.bbappend
index 4975e599..01480a65 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bbappend
+++ b/recipes-qt/qt5/qtdeclarative_git.bbappend
@@ -19,4 +19,4 @@
##
##############################################################################
-SRCREV = "2e6f7f362e62c3285e7d395aca607502c8e8160e"
+SRCREV = "18e77550f149722e0554f24ddfa326e03a9fef10"
diff --git a/recipes-qt/qt5/qtgraphicaleffects_git.bbappend b/recipes-qt/qt5/qtgraphicaleffects_git.bbappend
index 6e1888fc..f7b6d745 100644
--- a/recipes-qt/qt5/qtgraphicaleffects_git.bbappend
+++ b/recipes-qt/qt5/qtgraphicaleffects_git.bbappend
@@ -19,4 +19,4 @@
##
##############################################################################
-SRCREV = "6523d7c4843e1d4176035c46e1514c39bdcfc3bf"
+SRCREV = "d01a936b6454834e8ead7acc5838ee5c66541a55"
diff --git a/recipes-qt/qt5/qtimageformats_git.bbappend b/recipes-qt/qt5/qtimageformats_git.bbappend
index 87a191b7..9a837832 100644
--- a/recipes-qt/qt5/qtimageformats_git.bbappend
+++ b/recipes-qt/qt5/qtimageformats_git.bbappend
@@ -19,4 +19,4 @@
##
##############################################################################
-SRCREV = "bf5b49878d75d316f31225f76152e8381a3d5f0f"
+SRCREV = "cbf2d7e7696a4a08360c2004dfcbb8be7c1d2edb"
diff --git a/recipes-qt/qt5/qtlocation_git.bbappend b/recipes-qt/qt5/qtlocation_git.bbappend
index 68d18326..8397e50e 100644
--- a/recipes-qt/qt5/qtlocation_git.bbappend
+++ b/recipes-qt/qt5/qtlocation_git.bbappend
@@ -24,4 +24,4 @@ PACKAGECONFIG += "gypsy"
EXTRA_QMAKEVARS_PRE_emulator += "CONFIG+=simulator"
DEPENDS_emulator += "qtsimulator"
-SRCREV = "d1f66746ab0b77b4f3300cbeeaafe61d25d78e98"
+SRCREV = "2bdeea286037e5ea0d8ba0d2ad59bdf1eaae1054"
diff --git a/recipes-qt/qt5/qtmultimedia_git.bbappend b/recipes-qt/qt5/qtmultimedia_git.bbappend
index e6dc5abe..818bc01a 100644
--- a/recipes-qt/qt5/qtmultimedia_git.bbappend
+++ b/recipes-qt/qt5/qtmultimedia_git.bbappend
@@ -23,4 +23,4 @@ PACKAGECONFIG += "${@bb.utils.contains('DISTRO_FEATURES', 'alsa', 'alsa', '', d)
${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'gstreamer010', 'gstreamer010', 'gstreamer', d)}"
-SRCREV = "7553a0521356d0b28bacb8c8d07a25e4ba26097e"
+SRCREV = "711efc552d65f22b262e049c5a046198377519dc"
diff --git a/recipes-qt/qt5/qtquickcontrols2_git.bb b/recipes-qt/qt5/qtquickcontrols2_git.bb
index 44275014..26aa40e8 100644
--- a/recipes-qt/qt5/qtquickcontrols2_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols2_git.bb
@@ -31,7 +31,7 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtxmlpatterns qtdeclarative qtgraphicaleffects"
-SRCREV = "ac152bfcd37f94453e9705b57ca6520ad30bade0"
+SRCREV = "6ea6881ec8847dc99e05534769d6fe6198f56ead"
FILES_${PN}-qmldesigner += " \
${OE_QMAKE_PATH_QML}/*/*/*/designer \
diff --git a/recipes-qt/qt5/qtquickcontrols_git.bbappend b/recipes-qt/qt5/qtquickcontrols_git.bbappend
index 3a988d84..a52513ce 100644
--- a/recipes-qt/qt5/qtquickcontrols_git.bbappend
+++ b/recipes-qt/qt5/qtquickcontrols_git.bbappend
@@ -19,4 +19,6 @@
##
##############################################################################
-SRCREV = "26f7894dae87ef2dd6cf596decf645d1c877c950"
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRCREV = "fcc9c0206433c5c940a0872447899743d1a9996a"
diff --git a/recipes-qt/qt5/qtsensors_git.bbappend b/recipes-qt/qt5/qtsensors_git.bbappend
index f5301b42..dc59a6a1 100644
--- a/recipes-qt/qt5/qtsensors_git.bbappend
+++ b/recipes-qt/qt5/qtsensors_git.bbappend
@@ -22,4 +22,4 @@
EXTRA_QMAKEVARS_PRE_emulator += "SENSORS_PLUGINS=simulator"
DEPENDS_emulator += "qtsimulator"
-SRCREV = "0b00ee6f6c311a7f5c0b4f2441dad97a454d172e"
+SRCREV = "b08c3e69e3e82014b0f16b1ff94e5edd31d5c2c6"
diff --git a/recipes-qt/qt5/qtserialbus_git.bb b/recipes-qt/qt5/qtserialbus_git.bb
index fbb79aee..cfb710c6 100644
--- a/recipes-qt/qt5/qtserialbus_git.bb
+++ b/recipes-qt/qt5/qtserialbus_git.bb
@@ -31,4 +31,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtserialport"
-SRCREV = "edf55f657a46fe16bf80d63f523848bb9b71d9f3"
+SRCREV = "ec7b4b226818fa39646ec9c619b9df995952ea9c"
diff --git a/recipes-qt/qt5/qtserialport_git.bbappend b/recipes-qt/qt5/qtserialport_git.bbappend
index a625d74d..ef91dc4d 100644
--- a/recipes-qt/qt5/qtserialport_git.bbappend
+++ b/recipes-qt/qt5/qtserialport_git.bbappend
@@ -19,4 +19,4 @@
##
##############################################################################
-SRCREV = "9a70ee2389d3302f6a4262325f8a76e4d867b478"
+SRCREV = "c1355ae41ee46437e9d6583dc4ea452a82b6b53b"
diff --git a/recipes-qt/qt5/qtsvg_git.bbappend b/recipes-qt/qt5/qtsvg_git.bbappend
index f2d72924..c486a2d5 100644
--- a/recipes-qt/qt5/qtsvg_git.bbappend
+++ b/recipes-qt/qt5/qtsvg_git.bbappend
@@ -19,4 +19,4 @@
##
##############################################################################
-SRCREV = "e02df9c098b4d304b34c0ff65806a0576e45ed1a"
+SRCREV = "0e69a7c86f1908bc282362ec59f0ccf97d35d63a"
diff --git a/recipes-qt/qt5/qttools_git.bbappend b/recipes-qt/qt5/qttools_git.bbappend
index 740e3faa..232f920b 100644
--- a/recipes-qt/qt5/qttools_git.bbappend
+++ b/recipes-qt/qt5/qttools_git.bbappend
@@ -19,4 +19,4 @@
##
##############################################################################
-SRCREV = "e33532e048fa12ee32429ca83ee31aa8f065147d"
+SRCREV = "2d838dd06ebacc58c620614719067f6dac5e7418"
diff --git a/recipes-qt/qt5/qttranslations_git.bbappend b/recipes-qt/qt5/qttranslations_git.bbappend
index caba045d..aeac682a 100644
--- a/recipes-qt/qt5/qttranslations_git.bbappend
+++ b/recipes-qt/qt5/qttranslations_git.bbappend
@@ -19,4 +19,4 @@
##
##############################################################################
-SRCREV = "13f1f2f12ddfc9b84535361d77a5f0f0ec8c3e0f"
+SRCREV = "efa6513bbf2515fbe6ab7b365e9597a8900ae279"
diff --git a/recipes-qt/qt5/qtwayland-native_git.bbappend b/recipes-qt/qt5/qtwayland-native_git.bbappend
index 9fa91845..8849fd8b 100644
--- a/recipes-qt/qt5/qtwayland-native_git.bbappend
+++ b/recipes-qt/qt5/qtwayland-native_git.bbappend
@@ -19,4 +19,4 @@
##
##############################################################################
-SRCREV = "2e08d3afc08ea305052d75a306dac381d3025134"
+SRCREV = "920387296abcead6fea2d801fb2f57c185657c47"
diff --git a/recipes-qt/qt5/qtwayland_git.bbappend b/recipes-qt/qt5/qtwayland_git.bbappend
index 9fa91845..8849fd8b 100644
--- a/recipes-qt/qt5/qtwayland_git.bbappend
+++ b/recipes-qt/qt5/qtwayland_git.bbappend
@@ -19,4 +19,4 @@
##
##############################################################################
-SRCREV = "2e08d3afc08ea305052d75a306dac381d3025134"
+SRCREV = "920387296abcead6fea2d801fb2f57c185657c47"
diff --git a/recipes-qt/qt5/qtwebchannel_git.bbappend b/recipes-qt/qt5/qtwebchannel_git.bbappend
index 49cccebd..672745ee 100644
--- a/recipes-qt/qt5/qtwebchannel_git.bbappend
+++ b/recipes-qt/qt5/qtwebchannel_git.bbappend
@@ -19,4 +19,4 @@
##
##############################################################################
-SRCREV = "64a106da72796377bbff5cce0ecc5a379b105498"
+SRCREV = "b06c69533baeb2f80897f72ed787b51e122ffafc"
diff --git a/recipes-qt/qt5/qtwebengine_git.bbappend b/recipes-qt/qt5/qtwebengine_git.bbappend
index 87fc55a9..a7920fd2 100644
--- a/recipes-qt/qt5/qtwebengine_git.bbappend
+++ b/recipes-qt/qt5/qtwebengine_git.bbappend
@@ -25,5 +25,5 @@ SRC_URI_append_mx6 = " \
file://0001-Fix-slow-video-with-webengine-on-nitrogen6x.patch \
"
-SRCREV_qtwebengine = "a3318c84b022282a5a4a2babc51d1e3ca634e25b"
-SRCREV_chromium = "8252b18aa3efa52138e91f9756945afb142a1c8c"
+SRCREV_qtwebengine = "69351428413edb7a76ce2ca11634b1797e45e296"
+SRCREV_chromium = "dc08e3972d36a63dd477de0de005b3e81a5674d9"
diff --git a/recipes-qt/qt5/qtwebsockets_git.bbappend b/recipes-qt/qt5/qtwebsockets_git.bbappend
index 911457c2..8b8c9cdd 100644
--- a/recipes-qt/qt5/qtwebsockets_git.bbappend
+++ b/recipes-qt/qt5/qtwebsockets_git.bbappend
@@ -19,4 +19,4 @@
##
##############################################################################
-SRCREV = "ba9306ec5a1271275d79b2f48ceb227f79352f33"
+SRCREV = "0637eb3f40440f90eb531561e26f3854463bdbb3"
diff --git a/recipes-qt/qt5/qtxmlpatterns_git.bbappend b/recipes-qt/qt5/qtxmlpatterns_git.bbappend
index a057fb18..3150a1b8 100644
--- a/recipes-qt/qt5/qtxmlpatterns_git.bbappend
+++ b/recipes-qt/qt5/qtxmlpatterns_git.bbappend
@@ -19,4 +19,4 @@
##
##############################################################################
-SRCREV = "5e6acdb2ea92add793835561e7a2d6b0ed8890f8"
+SRCREV = "23b764d34705d0f858e428e02c910637368b2694"
diff --git a/scripts/manifest.xml b/scripts/manifest.xml
index 5912e6f7..282ce696 100644
--- a/scripts/manifest.xml
+++ b/scripts/manifest.xml
@@ -25,7 +25,7 @@
path="sources/meta-openembedded"/>
<project name="meta-qt5"
remote="qtyocto"
- revision="afb62012ec358e12fcad06e8096be1f6ec13f1ba"
+ revision="ce9a8d9537e3baa7d485128a3f41451d7dca7770"
path="sources/meta-qt5"/>
<project name="meta-mingw"
remote="qtyocto"