aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2019-11-04 16:08:59 +0200
committerMikko Gronoff <mikko.gronoff@qt.io>2019-11-07 07:09:27 +0200
commit5c6f28896967f74a8d93de353df49e32dbf8b446 (patch)
tree6812aa81417abb9fe39be07f8080f7f6a23ced14
parent52bffd406bf1d168139ada625a25eccdb13d006c (diff)
meta-qt5: update layer
Update to latest content in Qt 5.12.6 branch. Task-number: QTBUG-79724 Change-Id: I79511d0cfcfb65893be5b3e4d1f24976ab3d6aa4 Reviewed-by: Jani Heikkinen <jani.heikkinen@qt.io>
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/nativesdk-qtbase_git.bbappend5
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/qtbase/0001-disable-qt_random_cpu.patch25
-rw-r--r--scripts/manifest.xml2
3 files changed, 4 insertions, 28 deletions
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/nativesdk-qtbase_git.bbappend b/meta-boot2qt-distro/recipes-qt/qt5/nativesdk-qtbase_git.bbappend
index 36b44097..ba9db04d 100644
--- a/meta-boot2qt-distro/recipes-qt/qt5/nativesdk-qtbase_git.bbappend
+++ b/meta-boot2qt-distro/recipes-qt/qt5/nativesdk-qtbase_git.bbappend
@@ -1,6 +1,6 @@
############################################################################
##
-## Copyright (C) 2018 The Qt Company Ltd.
+## Copyright (C) 2019 The Qt Company Ltd.
## Contact: https://www.qt.io/licensing/
##
## This file is part of the Boot to Qt meta layer.
@@ -45,4 +45,5 @@ FILES_${PN}-dev += " \
fakeroot do_generate_qt_environment_file_mingw32() {
}
-SRC_URI_append_mingw32 = "file://0001-disable-qt_random_cpu.patch"
+# workaround for QTBUG-64707
+QT_CONFIG_FLAGS_append_mingw32 = " -no-feature-rdrnd"
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtbase/0001-disable-qt_random_cpu.patch b/meta-boot2qt-distro/recipes-qt/qt5/qtbase/0001-disable-qt_random_cpu.patch
deleted file mode 100644
index 26c78381..00000000
--- a/meta-boot2qt-distro/recipes-qt/qt5/qtbase/0001-disable-qt_random_cpu.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 655618933b78f53bb4338c8b7e3109da780ad3c6 Mon Sep 17 00:00:00 2001
-From: Samuli Piippo <samuli.piippo@qt.io>
-Date: Thu, 23 Nov 2017 11:28:47 +0200
-Subject: [PATCH] disable qt_random_cpu
-
-The code caused internal compiler error when compiling for mingw32
-
-Change-Id: Ieba798a9599a6d683c6630c6cd3731b2b909b628
----
- src/corelib/global/qrandom.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/corelib/global/qrandom.cpp b/src/corelib/global/qrandom.cpp
-index 6769190..c1a775a 100644
---- a/src/corelib/global/qrandom.cpp
-+++ b/src/corelib/global/qrandom.cpp
-@@ -92,7 +92,7 @@ DECLSPEC_IMPORT BOOLEAN WINAPI SystemFunction036(PVOID RandomBuffer, ULONG Rando
-
- QT_BEGIN_NAMESPACE
-
--#if defined(Q_PROCESSOR_X86) && QT_COMPILER_SUPPORTS_HERE(RDRND)
-+#if 0
- static qsizetype qt_random_cpu(void *buffer, qsizetype count) Q_DECL_NOTHROW;
-
- # ifdef Q_PROCESSOR_X86_64
diff --git a/scripts/manifest.xml b/scripts/manifest.xml
index 577c509d..b7bfa937 100644
--- a/scripts/manifest.xml
+++ b/scripts/manifest.xml
@@ -27,7 +27,7 @@
path="sources/meta-openembedded"/>
<project name="meta-qt5"
remote="qtyocto"
- revision="e8ee8bc088936129ca0d1335fc09c4e9e2a4aaa6"
+ revision="1607d0d8e15657df1a882d26b7fab729c45e8180"
path="sources/meta-qt5"/>
<project name="meta-mingw"
remote="qtyocto"