aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2019-11-28 12:13:22 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2019-12-03 10:10:33 +0000
commit6912408e3508d2dac2f9a26638b0db8fd3a0da74 (patch)
tree3c66ea48d209d013b4b74a1864db085e27d2b71b
parent7810d9dea618ec9ddc12ef2a9308d2204c629422 (diff)
neptune: add PACKAGECONFIG for ogl-runtime support
Change-Id: If15884b0c56789b8ae9be55748409bc051a18c15 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io> (cherry picked from commit warrior/5311798813357922854a8c2033ed0c02f31459b4)
-rw-r--r--meta-boot2qt/recipes-qt/automotive/neptune3-ui_git.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-boot2qt/recipes-qt/automotive/neptune3-ui_git.bb b/meta-boot2qt/recipes-qt/automotive/neptune3-ui_git.bb
index 2a98e07e..65616142 100644
--- a/meta-boot2qt/recipes-qt/automotive/neptune3-ui_git.bb
+++ b/meta-boot2qt/recipes-qt/automotive/neptune3-ui_git.bb
@@ -78,8 +78,9 @@ RDEPENDS_${PN} = "\
${@bb.utils.contains('DISTRO_FEATURES', 'webengine', 'qtwebengine', '', d)} \
"
-PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'qtsaferenderer', d)}"
+PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'qtsaferenderer', d)} ogl-runtime"
PACKAGECONFIG[qtsaferenderer] = "CONFIG+=use_qsr,,qtsaferenderer qtsaferenderer-native"
+PACKAGECONFIG[ogl-runtime] = ",,ogl-runtime,ogl-runtime"
EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}"