aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2019-10-16 15:47:33 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2019-10-16 15:47:33 +0300
commit981e0202f44caad6b172a84eddfc45d560903add (patch)
treec988ed938801e56f6198a119697fefa66fc3ff11
parente2c736df163c006f5642d97a914bbfe3d96c9a68 (diff)
parent56124e6eb5f95a42b178c2e16eafe0eff716d253 (diff)
Merge remote-tracking branch 'origin/5.13.1_QtAS' into thud
* origin/5.13.1_QtAS: Fix for ivigenerator use in boot2qt on windows platform Update automotive sha1s for QtAS 5.13.1 mingw: Fix bad cmd flag Update automotive sha1s for QtAS 5.13.1 qtlocation: enable all geoservice plugins qtsaferenderer: fix installation of missing plugin Update automotive sha1s for QtAS 5.13.1 neptune: hide mouse cursor Update automotive sha1s for QtAS 5.13.1 [qsr] new qsr and neptune services switching, set display for qsr Update automotive sha1s for QtAS 5.13.1 Update automotive sha1s for QtAS 5.13.1 Change-Id: Ib86c1893b1396dfcada5aa81fcdd0c76b2de2cf5
-rw-r--r--meta-boot2qt-distro/conf/distro/b2qt.conf1
-rw-r--r--meta-boot2qt-distro/conf/distro/include/preferred-providers-mingw32.inc9
-rw-r--r--meta-boot2qt-distro/recipes-core/meta/meta-environment.bbappend5
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/qtlocation_git.bbappend6
-rw-r--r--meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python.inc51
-rw-r--r--meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python_i686.bb3
-rw-r--r--meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python_x86_64.bb3
-rw-r--r--meta-boot2qt/recipes-qt/automotive/neptune3-ui/intel-corei7-64/kms-qsr.conf10
-rw-r--r--meta-boot2qt/recipes-qt/automotive/neptune3-ui/kms-qsr.conf3
-rw-r--r--meta-boot2qt/recipes-qt/automotive/neptune3-ui/neptune-qsr3
-rw-r--r--meta-boot2qt/recipes-qt/automotive/neptune3-ui/neptune-qsr.service11
-rw-r--r--meta-boot2qt/recipes-qt/automotive/neptune3-ui/neptune.service6
-rw-r--r--meta-boot2qt/recipes-qt/automotive/neptune3-ui_git.bb7
-rw-r--r--meta-boot2qt/recipes-qt/automotive/qmllive_git.bb2
-rw-r--r--meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb2
-rw-r--r--meta-boot2qt/recipes-qt/automotive/qtivi_git.bb3
-rw-r--r--meta-boot2qt/recipes-qt/automotive/qtsaferenderer/0002-Fix-libnetworkmsgplugin-install.patch33
-rw-r--r--meta-boot2qt/recipes-qt/automotive/qtsaferenderer_git.bb1
18 files changed, 144 insertions, 15 deletions
diff --git a/meta-boot2qt-distro/conf/distro/b2qt.conf b/meta-boot2qt-distro/conf/distro/b2qt.conf
index 7a70b5c1..76d6a10c 100644
--- a/meta-boot2qt-distro/conf/distro/b2qt.conf
+++ b/meta-boot2qt-distro/conf/distro/b2qt.conf
@@ -88,3 +88,4 @@ LICENSE_CREATE_PACKAGE = "1"
COPY_LIC_MANIFEST = "1"
include conf/distro/include/${MACHINE}.conf
+include conf/distro/include/preferred-providers-${SDK_OS}.inc
diff --git a/meta-boot2qt-distro/conf/distro/include/preferred-providers-mingw32.inc b/meta-boot2qt-distro/conf/distro/include/preferred-providers-mingw32.inc
new file mode 100644
index 00000000..28dc3a71
--- /dev/null
+++ b/meta-boot2qt-distro/conf/distro/include/preferred-providers-mingw32.inc
@@ -0,0 +1,9 @@
+PREFERRED_PROVIDER_nativesdk-antlr4-python3-runtime ?= "nativesdk-prebuild-python"
+PREFERRED_PROVIDER_nativesdk-python3 ?= "nativesdk-prebuild-python"
+PREFERRED_PROVIDER_nativesdk-python3-jinja2 ?= "nativesdk-prebuild-python"
+PREFERRED_PROVIDER_nativesdk-python3-markupsafe ?= "nativesdk-prebuild-python"
+PREFERRED_PROVIDER_nativesdk-python3-path.py ?= "nativesdk-prebuild-python"
+PREFERRED_PROVIDER_nativesdk-python3-pathtools ?= "nativesdk-prebuild-python"
+PREFERRED_PROVIDER_nativesdk-qface ?= "nativesdk-prebuild-python"
+PREFERRED_PROVIDER_nativesdk-python3-setuptools-scm ?= "nativesdk-prebuild-python"
+PREFERRED_PROVIDER_nativesdk-python3-watchdog ?= "nativesdk-prebuild-python"
diff --git a/meta-boot2qt-distro/recipes-core/meta/meta-environment.bbappend b/meta-boot2qt-distro/recipes-core/meta/meta-environment.bbappend
index 65cc6b33..4352f438 100644
--- a/meta-boot2qt-distro/recipes-core/meta/meta-environment.bbappend
+++ b/meta-boot2qt-distro/recipes-core/meta/meta-environment.bbappend
@@ -33,3 +33,8 @@ toolchain_create_sdk_version_append () {
echo 'Layer Revisions:' >> $versionfile
echo '${@get_layer_revs(d)}' >> $versionfile
}
+
+# Fix bad cmd flag
+toolchain_create_sdk_env_script_append_sdkmingw32() {
+ sed -i -e '/@%COMSPEC/s/\\/\//' $script
+}
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtlocation_git.bbappend b/meta-boot2qt-distro/recipes-qt/qt5/qtlocation_git.bbappend
index c7112cfa..59f0d552 100644
--- a/meta-boot2qt-distro/recipes-qt/qt5/qtlocation_git.bbappend
+++ b/meta-boot2qt-distro/recipes-qt/qt5/qtlocation_git.bbappend
@@ -28,8 +28,10 @@
############################################################################
PACKAGECONFIG += " \
- geoservices_mapbox \
+ geoservices_esri \
+ geoservices_here \
geoservices_itemsoverlay \
+ geoservices_mapbox \
geoservices_mapboxgl \
+ geoservices_osm \
"
-
diff --git a/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python.inc b/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python.inc
index 3d8c083f..f7c33a13 100644
--- a/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python.inc
+++ b/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python.inc
@@ -39,15 +39,64 @@ PV = "3.5.2"
S = "${WORKDIR}"
+PROVIDES += " \
+ python3 \
+ python3-watchdog \
+ python3-path.py \
+ antlr4-python3-runtime \
+ python3-jinja2 \
+ python3-markupsafe \
+ qface \
+ "
+
+RPROVIDES_${PN} += " \
+ python3-pkgutil \
+ python3-xml \
+ python3-crypt \
+ python3-compile \
+ python3-netserver \
+ python3-compression \
+ python3-numbers \
+ python3-unittest \
+ python3-netclient \
+ python3-math \
+ python3-ctypes \
+ python3-html \
+ python3-json \
+ python3-datetime \
+ python3-distutils \
+ python3-shell \
+ python3-stringold \
+ python3-email \
+ python3-threading \
+ python3-pprint \
+ python3-plistlib \
+ python3-io \
+ python3-pickle \
+ \
+ qface \
+ python3-jinja2 \
+ python3-watchdog \
+ python3-path.py \
+ python3-markupsafe \
+ antlr4-python3-runtime \
+ "
+
do_install() {
install -d ${D}${includedir}/${PYTHON_DIR}
install -m 0644 ${S}/include/* ${D}${includedir}/${PYTHON_DIR}
+ install -d ${D}${bindir}
install -d ${D}${libdir}
+ install -d ${D}${libdir}/${PYTHON_DIR}
install -m 0644 ${S}/libs/*.a ${D}${libdir}
+ cp -r --no-preserve=ownership ${S}/Lib/* ${D}/${libdir}/${PYTHON_DIR}/
+ cp -r --no-preserve=ownership ${S}/Lib/site-packages/* ${D}/${bindir}/
- install -d ${D}${bindir}
+ install -m 0644 ${S}/*.pyd ${D}/${bindir}/
install -m 0644 ${S}/python.exe ${D}${bindir}
+ install -m 0644 ${S}/python.exe ${D}${bindir}/python3.exe
install -m 0644 ${S}/python35.dll ${D}${bindir}
install -m 0644 ${S}/python35.zip ${D}${bindir}
+ install -m 0644 ${S}/Scripts/* ${D}${bindir}
}
diff --git a/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python_i686.bb b/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python_i686.bb
index 2ff4f761..78b9f8f9 100644
--- a/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python_i686.bb
+++ b/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python_i686.bb
@@ -34,9 +34,12 @@ COMPATIBLE_HOST = "i686.*-mingw.*"
SRC_URI = "\
https://download.qt.io/development_releases/prebuilt/python/Python35-win-x86.7z \
https://www.python.org/ftp/python/${PV}/python-${PV}-embed-win32.zip;name=bin \
+ https://download.qt.io/development_releases/prebuilt/python/python-${PV}-modules-win32.zip;name=modules \
"
SRC_URI[md5sum] = "3da266445a4e6a93ff1949810141da8f"
SRC_URI[sha256sum] = "b60c49227c6e920904d784681c16ee3591a18824c3abb89613813f93fde1c1f2"
SRC_URI[bin.md5sum] = "ad637a1db7cf91e344318d55c94ad3ca"
SRC_URI[bin.sha256sum] = "75f05800fbe4a8cd6672b268ca53244838684561e03c60c668a7dccb050eb954"
+SRC_URI[modules.md5sum] = "c44f01754f9975ae6d910783d69e6a28"
+SRC_URI[modules.sha256sum] = "13bbbcc724165407cfbec8d23424bd94f45541092f08523f0064f75e6c4de5ae"
diff --git a/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python_x86_64.bb b/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python_x86_64.bb
index 8e69fbd7..71b6c4b6 100644
--- a/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python_x86_64.bb
+++ b/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python_x86_64.bb
@@ -34,9 +34,12 @@ COMPATIBLE_HOST = "x86_64.*-mingw.*"
SRC_URI = "\
https://download.qt.io/development_releases/prebuilt/python/Python35-win-x64.7z \
https://www.python.org/ftp/python/${PV}/python-${PV}-embed-amd64.zip;name=bin \
+ https://download.qt.io/development_releases/prebuilt/python/python-${PV}-modules-amd64.zip;name=modules \
"
SRC_URI[md5sum] = "08766b13bcbdcf8217a98bfc291d549f"
SRC_URI[sha256sum] = "43e38c8a05dcbc2effd1915dbe2dc2be6e701ebf3eb00d6e45197ee773978124"
SRC_URI[bin.md5sum] = "f1c24bb78bd6dd792a73d5ebfbd3b20e"
SRC_URI[bin.sha256sum] = "faefbd98f61c0d87c5683eeb526ae4d4a9ddc369bef27870cfe1c8939329d066"
+SRC_URI[modules.md5sum] = "bf1deaf0a0b807bcd52e11d15892fec2"
+SRC_URI[modules.sha256sum] = "cd82789e05bf763b3b67f8e3ec78873c69ce922a13e391298be198702967d6da"
diff --git a/meta-boot2qt/recipes-qt/automotive/neptune3-ui/intel-corei7-64/kms-qsr.conf b/meta-boot2qt/recipes-qt/automotive/neptune3-ui/intel-corei7-64/kms-qsr.conf
new file mode 100644
index 00000000..9d898b2f
--- /dev/null
+++ b/meta-boot2qt/recipes-qt/automotive/neptune3-ui/intel-corei7-64/kms-qsr.conf
@@ -0,0 +1,10 @@
+{
+ "hwcursor": false,
+ "outputs": [
+ {
+ "name": "DP3",
+ "virtualIndex": 0,
+ "primary": true
+ }
+ ]
+}
diff --git a/meta-boot2qt/recipes-qt/automotive/neptune3-ui/kms-qsr.conf b/meta-boot2qt/recipes-qt/automotive/neptune3-ui/kms-qsr.conf
new file mode 100644
index 00000000..f003a7fd
--- /dev/null
+++ b/meta-boot2qt/recipes-qt/automotive/neptune3-ui/kms-qsr.conf
@@ -0,0 +1,3 @@
+{
+ "hwcursor": false
+}
diff --git a/meta-boot2qt/recipes-qt/automotive/neptune3-ui/neptune-qsr b/meta-boot2qt/recipes-qt/automotive/neptune3-ui/neptune-qsr
new file mode 100644
index 00000000..5544a53a
--- /dev/null
+++ b/meta-boot2qt/recipes-qt/automotive/neptune3-ui/neptune-qsr
@@ -0,0 +1,3 @@
+QT_QPA_EGLFS_KMS_CONFIG=/etc/kms-qsr.conf
+QSR_SHOW_TEXT_ON_STARTUP=1
+QSR_FILL_BLACK_BACKGROUND=1
diff --git a/meta-boot2qt/recipes-qt/automotive/neptune3-ui/neptune-qsr.service b/meta-boot2qt/recipes-qt/automotive/neptune3-ui/neptune-qsr.service
index 340f4c02..78b26749 100644
--- a/meta-boot2qt/recipes-qt/automotive/neptune3-ui/neptune-qsr.service
+++ b/meta-boot2qt/recipes-qt/automotive/neptune3-ui/neptune-qsr.service
@@ -1,13 +1,14 @@
[Unit]
-Description=Neptune
-After=dbus.service dbus-session.service systemd-user-sessions.service ivi-services.target
+Description=Neptune3-UI-QSR
+After=dbus-session.service systemd-user-sessions.service ivi-services.target
Wants=ivi-services.target
+After=neptune.service
Conflicts=neptune.service
[Service]
User=root
-ExecStart=/usr/bin/appcontroller /opt/neptune3/neptune3-ui-qsr-cluster
+ExecStart=/opt/neptune3/neptune3-ui-qsr-cluster
Restart=on-failure
WorkingDirectory=/opt/neptune3
-Environment=AM_STARTUP_TIMER=1
-Environment=QT_QPA_PLATFORM=linuxfb
+EnvironmentFile=/etc/default/qt
+EnvironmentFile=/etc/default/neptune-qsr
diff --git a/meta-boot2qt/recipes-qt/automotive/neptune3-ui/neptune.service b/meta-boot2qt/recipes-qt/automotive/neptune3-ui/neptune.service
index c5aa8b66..e2822e74 100644
--- a/meta-boot2qt/recipes-qt/automotive/neptune3-ui/neptune.service
+++ b/meta-boot2qt/recipes-qt/automotive/neptune3-ui/neptune.service
@@ -1,16 +1,18 @@
[Unit]
-Description=Neptune
+Description=Neptune3-UI
After=dbus.service dbus-session@root.service systemd-user-sessions.service ivi-services.target
Wants=ivi-services.target dbus-session@root.service
Conflicts=neptune-qsr.service
+Before=neptune-qsr.service
+OnFailure=neptune-qsr.service
[Service]
User=root
ExecStart=/opt/neptune3/neptune3-ui -r --dbus session -c am-config-neptune.yaml
-Restart=on-failure
WorkingDirectory=/opt/neptune3
EnvironmentFile=/etc/default/qt
Environment=AM_STARTUP_TIMER=1
+Environment=QT_QPA_EGLFS_HIDECURSOR=1
[Install]
WantedBy=multi-user.target
diff --git a/meta-boot2qt/recipes-qt/automotive/neptune3-ui_git.bb b/meta-boot2qt/recipes-qt/automotive/neptune3-ui_git.bb
index aec372ee..dd537d17 100644
--- a/meta-boot2qt/recipes-qt/automotive/neptune3-ui_git.bb
+++ b/meta-boot2qt/recipes-qt/automotive/neptune3-ui_git.bb
@@ -45,11 +45,13 @@ SRC_URI += " \
file://neptune-qsr.service \
file://drivedata-simulation-server.service \
file://remotesettings-server.service \
+ file://kms-qsr.conf \
+ file://neptune-qsr \
"
SRC_URI_append_mx6 = " file://0001_hardware_variant_low.patch"
SRC_URI_append_rpi = " file://0001_hardware_variant_low.patch"
-SRCREV = "d375b489e37e19c56c2826c16c0d4ef410d86450"
+SRCREV = "d1e180a525775b86da5dd071f167578464dab98f"
QMAKE_PROFILES = "${S}/neptune3-ui.pro"
@@ -87,6 +89,9 @@ do_install_append() {
if ${@bb.utils.contains('PACKAGECONFIG','qtsaferenderer','true','false',d)}; then
install -m 0644 ${WORKDIR}/neptune-qsr.service ${D}${systemd_unitdir}/system/
+ install -m 0755 -d ${D}${sysconfdir}/default
+ install -m 0644 ${WORKDIR}/kms-qsr.conf ${D}${sysconfdir}/
+ install -m 0644 ${WORKDIR}/neptune-qsr ${D}${sysconfdir}/default/
fi
# Don't install duplicate fonts, they are same as ttf-opensans
diff --git a/meta-boot2qt/recipes-qt/automotive/qmllive_git.bb b/meta-boot2qt/recipes-qt/automotive/qmllive_git.bb
index 632525b9..9b9e0fce 100644
--- a/meta-boot2qt/recipes-qt/automotive/qmllive_git.bb
+++ b/meta-boot2qt/recipes-qt/automotive/qmllive_git.bb
@@ -37,7 +37,7 @@ require recipes-qt/qt5/qt5-git.inc
QT_GIT_PROJECT = "qt-apps"
-SRCREV = "ee3277bf453502f0864e591740b1da785c4cc614"
+SRCREV = "b5b1f8797925ffd495603b9417a3c71099a1a55c"
DEPENDS = "qtbase qtdeclarative"
diff --git a/meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb b/meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb
index 91245dc0..2a206993 100644
--- a/meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb
+++ b/meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb
@@ -34,7 +34,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504"
inherit qt5-module
require recipes-qt/qt5/qt5-git.inc
-SRCREV = "5f05117fb8c31ad58937d6b5bd55139a697c2673"
+SRCREV = "f73ca6c1fa06d83fb44c7f56189c659b29db0ea0"
DEPENDS = "qtbase qtdeclarative libyaml libarchive \
${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland qtwayland-native", "", d)}"
diff --git a/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb b/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb
index 03532424..019e687d 100644
--- a/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb
+++ b/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb
@@ -54,7 +54,7 @@ SRC_URI += " \
file://ivi-services.target \
"
-SRCREV = "a75c835d3eda43961faeefc370c59992f3d3268a"
+SRCREV = "ffb90d001e085d297aa15d92b1e4818372494366"
PACKAGECONFIG ?= "taglib ivigenerator remoteobjects"
PACKAGECONFIG[taglib] = "QMAKE_EXTRA_ARGS+=-feature-taglib,QMAKE_EXTRA_ARGS+=-no-feature-taglib,taglib"
@@ -69,7 +69,6 @@ PACKAGECONFIG[remoteobjects-native] = "QMAKE_EXTRA_ARGS+=-feature-remoteobjects
PACKAGECONFIG_class-native ??= "host-tools-only ivigenerator-native remoteobjects-native"
PACKAGECONFIG_class-nativesdk ??= "${PACKAGECONFIG_class-native}"
-PACKAGECONFIG_class-nativesdk_mingw32 ??= "host-tools-only"
ALLOW_EMPTY_${PN}-tools = "1"
diff --git a/meta-boot2qt/recipes-qt/automotive/qtsaferenderer/0002-Fix-libnetworkmsgplugin-install.patch b/meta-boot2qt/recipes-qt/automotive/qtsaferenderer/0002-Fix-libnetworkmsgplugin-install.patch
new file mode 100644
index 00000000..f2427a56
--- /dev/null
+++ b/meta-boot2qt/recipes-qt/automotive/qtsaferenderer/0002-Fix-libnetworkmsgplugin-install.patch
@@ -0,0 +1,33 @@
+From 6e3acb41295b93127b2b0e3da3068303406d7b13 Mon Sep 17 00:00:00 2001
+From: Teemu Holappa <teemu.holappa@qt.io>
+Date: Tue, 8 Oct 2019 14:43:22 +0300
+Subject: [PATCH] Fix libnetworkmsgplugin install
+
+Task-number: QSR-559
+Change-Id: I27438325bcdaac0bff9156cfdb183898a40210d1
+Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
+---
+ src/messagesenderplugin/networkmsg/networkmsg.pro | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/messagesenderplugin/networkmsg/networkmsg.pro b/src/messagesenderplugin/networkmsg/networkmsg.pro
+index 6094fb9..1925238 100644
+--- a/src/messagesenderplugin/networkmsg/networkmsg.pro
++++ b/src/messagesenderplugin/networkmsg/networkmsg.pro
+@@ -3,7 +3,9 @@ TARGET = $$qtLibraryTarget(networkmsgplugin)
+ TEMPLATE = lib
+ CONFIG += plugin
+
+-DESTDIR=$$[QT_INSTALL_PLUGINS]/$$replace(uri, \\., /)/saferenderer
++PLUGIN_TYPE = saferenderer
++target.path = $$[QT_INSTALL_PLUGINS]/$$PLUGIN_TYPE
++INSTALLS += target
+
+ # The following define makes your compiler emit warnings if you use
+ # any feature of Qt which has been marked as deprecated (the exact warnings
+@@ -27,5 +29,3 @@ HEADERS += \
+ $$PWD/../messagesenderinterface_p.h \
+ $$PWD/../../saferenderer/qsafeevent.h
+ DISTFILES += networkmsgplugin.json
+-
+-
diff --git a/meta-boot2qt/recipes-qt/automotive/qtsaferenderer_git.bb b/meta-boot2qt/recipes-qt/automotive/qtsaferenderer_git.bb
index a012c957..499934bf 100644
--- a/meta-boot2qt/recipes-qt/automotive/qtsaferenderer_git.bb
+++ b/meta-boot2qt/recipes-qt/automotive/qtsaferenderer_git.bb
@@ -51,6 +51,7 @@ BRANCH = "1.1"
SRC_URI = "\
git://codereview.qt-project.org/tqtc-boot2qt/qtsaferenderer;branch=${BRANCH};protocol=ssh;sdk-uri=Src/QtSafeRenderer-1.1.1 \
file://0001-Fix-yocto-build-issues.patch \
+ file://0002-Fix-libnetworkmsgplugin-install.patch \
"
SRCREV = "e31a035f69bbc7280fc6e01e0c1031ac569b84a7"