aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorUlf Hermann <ulf.hermann@qt.io>2018-04-24 12:21:02 +0200
committerUlf Hermann <ulf.hermann@qt.io>2018-04-25 08:53:19 +0000
commit9484422a256f2b2d8aea29302a76d03bff377bfb (patch)
tree05c543f7a8c2759f13efb5e8dd3c1e94fc6e51e6
parent59e7092a7fd85186157ce87b70fedda1d190e0e5 (diff)
Enable uprobes for raspberrypi
Task-number: QTBUG-67891 Change-Id: Ie9e2e6775aeb5fca16d624a02ef570447a97145d Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r--meta-raspberrypi-extras/recipes/linux/linux-raspberrypi_%.bbappend32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-raspberrypi-extras/recipes/linux/linux-raspberrypi_%.bbappend b/meta-raspberrypi-extras/recipes/linux/linux-raspberrypi_%.bbappend
new file mode 100644
index 00000000..d6ea12fa
--- /dev/null
+++ b/meta-raspberrypi-extras/recipes/linux/linux-raspberrypi_%.bbappend
@@ -0,0 +1,32 @@
+############################################################################
+##
+## Copyright (C) 2018 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+do_configure_prepend() {
+ echo "CONFIG_UPROBE_EVENT=y" >> ${WORKDIR}/defconfig
+}