aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2018-04-20 14:17:33 +0300
committerMikko Gronoff <mikko.gronoff@qt.io>2018-04-20 14:19:13 +0300
commit61b4e74f5daaa43cde2a7594e8f70cbd2364263e (patch)
treeacc6a88e44bf684a8de484ca56f222c32eb35fe4
parent28a32f08bb3c24081efa28598125a663b3ea264b (diff)
parent6e3ac7bfe108acf3e84d073f9067302a39709f2f (diff)
Merge remote-tracking branch 'origin/morty' into pyro
* origin/morty: 6e3ac7b meta-qt5: update meta layer b250388 meta-qt5: update meta layer 763a607 qtdeviceutilities: update revision 0c1582c poky: update to latest revision in morty branch 4489683 nuc: use modprobe to load kernel module 45f1fec quickcompiler: Update QC to 5.9.5 version 65f8274 nuc: enable boot from internal sd cardreader Conflicts: meta-boot2qt/recipes-graphics/hunspell/hunspell-dicts_git.bb meta-boot2qt/recipes-qt/qt5/qtdeviceutilities_git.bb scripts/manifest.xml Change-Id: I6fbfe531d34716aacb4a7220c4fc2688152651a2
-rw-r--r--meta-boot2qt/recipes-core/initramfs-basic/files/init.sh5
-rw-r--r--meta-intel-extras/recipes/initramfs-basic/init-basic.bbappend38
-rw-r--r--meta-intel-extras/recipes/initramfs-basic/init-basic/init-device.sh3
-rw-r--r--meta-intel-extras/recipes/initramfs-basic/initramfs-basic.bbappend30
-rw-r--r--meta-intel-extras/recipes/linux/linux-intel/b2qt.cfg2
5 files changed, 78 insertions, 0 deletions
diff --git a/meta-boot2qt/recipes-core/initramfs-basic/files/init.sh b/meta-boot2qt/recipes-core/initramfs-basic/files/init.sh
index 3db235b9..94eb39b5 100644
--- a/meta-boot2qt/recipes-core/initramfs-basic/files/init.sh
+++ b/meta-boot2qt/recipes-core/initramfs-basic/files/init.sh
@@ -96,6 +96,11 @@ main() {
early_setup
read_args
+
+ if [ -f init-device ]; then
+ source init-device
+ fi
+
switch_real_root
}
diff --git a/meta-intel-extras/recipes/initramfs-basic/init-basic.bbappend b/meta-intel-extras/recipes/initramfs-basic/init-basic.bbappend
new file mode 100644
index 00000000..ab69a09e
--- /dev/null
+++ b/meta-intel-extras/recipes/initramfs-basic/init-basic.bbappend
@@ -0,0 +1,38 @@
+############################################################################
+##
+## Copyright (C) 2018 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://init-device.sh"
+
+do_install_append () {
+ install -m 0755 ${WORKDIR}/init-device.sh ${D}/init-device
+}
+
+FILES_${PN} += "/init-device"
diff --git a/meta-intel-extras/recipes/initramfs-basic/init-basic/init-device.sh b/meta-intel-extras/recipes/initramfs-basic/init-basic/init-device.sh
new file mode 100644
index 00000000..09eadbfb
--- /dev/null
+++ b/meta-intel-extras/recipes/initramfs-basic/init-basic/init-device.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+modprobe rtsx_pci_sdmmc
diff --git a/meta-intel-extras/recipes/initramfs-basic/initramfs-basic.bbappend b/meta-intel-extras/recipes/initramfs-basic/initramfs-basic.bbappend
new file mode 100644
index 00000000..1ac5f03a
--- /dev/null
+++ b/meta-intel-extras/recipes/initramfs-basic/initramfs-basic.bbappend
@@ -0,0 +1,30 @@
+############################################################################
+##
+## Copyright (C) 2018 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+PACKAGE_INSTALL += "kernel-module-rtsx-pci-sdmmc"
diff --git a/meta-intel-extras/recipes/linux/linux-intel/b2qt.cfg b/meta-intel-extras/recipes/linux/linux-intel/b2qt.cfg
index 79027988..af765b53 100644
--- a/meta-intel-extras/recipes/linux/linux-intel/b2qt.cfg
+++ b/meta-intel-extras/recipes/linux/linux-intel/b2qt.cfg
@@ -1 +1,3 @@
CONFIG_HID_MULTITOUCH=m
+CONFIG_MMC_REALTEK_PCI=m
+CONFIG_MFD_RTSX_PCI=m