aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2018-05-24 18:16:16 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2018-10-15 15:21:43 +0000
commit5832bf2747a70257eca5c443fd487532d62c90b3 (patch)
treea0351189e27fcd12241b9fef5f38422ac0ebbd0a
parent0c7eb257c3b0f03592e407e13c635d9e523fbcd0 (diff)
qtbase: don't use thumb for armv[45]
* it fails when building with gcc8 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtbase_git.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 6bf42643..e8f967ec 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -173,6 +173,11 @@ deltask generate_qt_config_file
XPLATFORM_toolchain-clang = "linux-oe-clang"
XPLATFORM ?= "linux-oe-g++"
+# Causes qdrawhelper.s: Error: unaligned opcodes detected in executable segment
+# when building qtbase/5.6.3+gitAUTOINC+e6f8b072d2-r0/git/src/gui/painting/qdrawhelper.cpp
+ARM_INSTRUCTION_SET_armv4 = "arm"
+ARM_INSTRUCTION_SET_armv5 = "arm"
+
do_configure() {
# Regenerate header files when they are included in source tarball
# Otherwise cmake files don't set PRIVATE_HEADERS correctly