aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2018-09-25 23:21:42 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2018-09-25 23:34:28 +0000
commit5c5b7e8721b068f3557e251ecc40e61c34ca6ed1 (patch)
treefe1fff0236a469b2b494c61e12caf0b6c70b56e0
parent333437ca8deffa2e2f9d02ae7165c03b4eacdb0d (diff)
qt5-creator: refresh .patch files and push them to meta-qt5 fork
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qt5-creator/0001-Fix-Allow-qt-creator-to-build-on-arm-aarch32-and-aar.patch4
-rw-r--r--recipes-qt/qt5/qt5-creator/0002-Use-correct-path-prefix.patch (renamed from recipes-qt/qt5/qt5-creator/linguisttool.patch)19
-rw-r--r--recipes-qt/qt5/qt5-creator/0003-botan-check-for-i386-x86_64.patch28
-rw-r--r--recipes-qt/qt5/qt5-creator/0004-Link-with-libexecinfo-on-musl.patch (renamed from recipes-qt/qt5/qt5-creator/0002-Link-with-libexecinfo-on-musl.patch)4
-rw-r--r--recipes-qt/qt5/qt5-creator/botan-non-x86.patch19
-rw-r--r--recipes-qt/qt5/qt5-creator_4.5.1.bb10
6 files changed, 51 insertions, 33 deletions
diff --git a/recipes-qt/qt5/qt5-creator/0001-Fix-Allow-qt-creator-to-build-on-arm-aarch32-and-aar.patch b/recipes-qt/qt5/qt5-creator/0001-Fix-Allow-qt-creator-to-build-on-arm-aarch32-and-aar.patch
index 28dc4755..ea336360 100644
--- a/recipes-qt/qt5/qt5-creator/0001-Fix-Allow-qt-creator-to-build-on-arm-aarch32-and-aar.patch
+++ b/recipes-qt/qt5/qt5-creator/0001-Fix-Allow-qt-creator-to-build-on-arm-aarch32-and-aar.patch
@@ -14,7 +14,7 @@ Change-Id: Iddea28f21c9fa1afd2fdd5d16a44e6c96a516a7a
2 files changed, 17 insertions(+), 1 deletion(-)
diff --git a/src/libs/3rdparty/botan/botan.cpp b/src/libs/3rdparty/botan/botan.cpp
-index 87736d5..2e950d8 100644
+index 87736d5fe3..2e950d88bf 100644
--- a/src/libs/3rdparty/botan/botan.cpp
+++ b/src/libs/3rdparty/botan/botan.cpp
@@ -1101,6 +1101,8 @@ class Montgomery_Exponentiator : public Modular_Exponentiator
@@ -76,7 +76,7 @@ index 87736d5..2e950d8 100644
* Helper Macros for x86 Assembly
*/
diff --git a/src/libs/3rdparty/botan/botan.h b/src/libs/3rdparty/botan/botan.h
-index d7b90cc..26ca8ac 100644
+index d7b90cc92f..26ca8aca37 100644
--- a/src/libs/3rdparty/botan/botan.h
+++ b/src/libs/3rdparty/botan/botan.h
@@ -85,7 +85,9 @@
diff --git a/recipes-qt/qt5/qt5-creator/linguisttool.patch b/recipes-qt/qt5/qt5-creator/0002-Use-correct-path-prefix.patch
index 6f92d6ab..1c589cad 100644
--- a/recipes-qt/qt5/qt5-creator/linguisttool.patch
+++ b/recipes-qt/qt5/qt5-creator/0002-Use-correct-path-prefix.patch
@@ -1,11 +1,20 @@
-Remove path prefix so it can find these tools from buildhost or native packages
+From 22ff2f705ee47d41c41a0a39bbda454ce54f9819 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Tue, 25 Sep 2018 23:15:08 +0000
+Subject: [PATCH] Use correct path prefix
Upstream-Status: Pending
+
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-Index: qt-creator-opensource-src-4.5.1/share/qtcreator/translations/translations.pro
-===================================================================
---- qt-creator-opensource-src-4.5.1.orig/share/qtcreator/translations/translations.pro
-+++ qt-creator-opensource-src-4.5.1/share/qtcreator/translations/translations.pro
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+---
+ share/qtcreator/translations/translations.pro | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/share/qtcreator/translations/translations.pro b/share/qtcreator/translations/translations.pro
+index 5f752f2855..87bc3d9cab 100644
+--- a/share/qtcreator/translations/translations.pro
++++ b/share/qtcreator/translations/translations.pro
@@ -12,10 +12,10 @@ defineReplace(prependAll) {
return($$result)
}
diff --git a/recipes-qt/qt5/qt5-creator/0003-botan-check-for-i386-x86_64.patch b/recipes-qt/qt5/qt5-creator/0003-botan-check-for-i386-x86_64.patch
new file mode 100644
index 00000000..32671815
--- /dev/null
+++ b/recipes-qt/qt5/qt5-creator/0003-botan-check-for-i386-x86_64.patch
@@ -0,0 +1,28 @@
+From 925868614c475d9e90bff8d9a33525f5d65d907c Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Tue, 25 Sep 2018 23:17:42 +0000
+Subject: [PATCH] botan: check for i386 || x86_64
+
+Just check for x86 or x86_64 to define X86 based support
+This makes sure it compiles for non-x86 platforms
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+---
+ src/libs/3rdparty/botan/botan.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/libs/3rdparty/botan/botan.h b/src/libs/3rdparty/botan/botan.h
+index 26ca8aca37..969405c56e 100644
+--- a/src/libs/3rdparty/botan/botan.h
++++ b/src/libs/3rdparty/botan/botan.h
+@@ -85,7 +85,7 @@
+ #endif
+
+ #define BOTAN_TARGET_CPU_IS_LITTLE_ENDIAN
+-#if !defined(__arm__) && !defined(__aarch64__)
++#if defined(__i386__) || defined(__x86_64__)
+ #define BOTAN_TARGET_CPU_IS_X86_FAMILY
+ #endif
+ #define BOTAN_TARGET_UNALIGNED_MEMORY_ACCESS_OK 1
diff --git a/recipes-qt/qt5/qt5-creator/0002-Link-with-libexecinfo-on-musl.patch b/recipes-qt/qt5/qt5-creator/0004-Link-with-libexecinfo-on-musl.patch
index 40e277fe..93938428 100644
--- a/recipes-qt/qt5/qt5-creator/0002-Link-with-libexecinfo-on-musl.patch
+++ b/recipes-qt/qt5/qt5-creator/0004-Link-with-libexecinfo-on-musl.patch
@@ -1,4 +1,4 @@
-From a30f4335d49516eb4654111af5bf073b633f7336 Mon Sep 17 00:00:00 2001
+From 9841dfba76dba7812405418049f259802cd06163 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Tue, 16 Jan 2018 13:26:57 +0000
Subject: [PATCH] Link with libexecinfo on musl
@@ -10,7 +10,7 @@ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
1 file changed, 1 insertion(+)
diff --git a/src/plugins/debugger/debugger.pro b/src/plugins/debugger/debugger.pro
-index f5a34aa..4a1359d 100644
+index f5a34aa0d5..4a1359dd5c 100644
--- a/src/plugins/debugger/debugger.pro
+++ b/src/plugins/debugger/debugger.pro
@@ -141,3 +141,4 @@ include(console/console.pri)
diff --git a/recipes-qt/qt5/qt5-creator/botan-non-x86.patch b/recipes-qt/qt5/qt5-creator/botan-non-x86.patch
deleted file mode 100644
index 5c83340c..00000000
--- a/recipes-qt/qt5/qt5-creator/botan-non-x86.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-Just check for x86 or x86_64 to define X86 based support
-This makes sure it compiles for non-x86 platforms
-
-Upstream-Status: Pending
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-
-Index: qt-creator-opensource-src-4.5.1/src/libs/3rdparty/botan/botan.h
-===================================================================
---- qt-creator-opensource-src-4.5.1.orig/src/libs/3rdparty/botan/botan.h
-+++ qt-creator-opensource-src-4.5.1/src/libs/3rdparty/botan/botan.h
-@@ -85,7 +85,7 @@
- #endif
-
- #define BOTAN_TARGET_CPU_IS_LITTLE_ENDIAN
--#if !defined(__arm__) && !defined(__aarch64__)
-+#if defined(__i386__) || defined(__x86_64__)
- #define BOTAN_TARGET_CPU_IS_X86_FAMILY
- #endif
- #define BOTAN_TARGET_UNALIGNED_MEMORY_ACCESS_OK 1
diff --git a/recipes-qt/qt5/qt5-creator_4.5.1.bb b/recipes-qt/qt5/qt5-creator_4.5.1.bb
index 91db48cb..6451b334 100644
--- a/recipes-qt/qt5/qt5-creator_4.5.1.bb
+++ b/recipes-qt/qt5/qt5-creator_4.5.1.bb
@@ -17,16 +17,16 @@ inherit qmake5
DEPENDS = "qtbase qtscript qtwebkit qtxmlpatterns qtx11extras qtdeclarative qttools qttools-native qtsvg chrpath-replacement-native"
DEPENDS_append_libc-musl = " libexecinfo"
-# Patches from https://github.com/meta-qt5/qtcreator/commits/b5.4.1
-# 5.4.1.meta-qt5.1
+# Patches from https://github.com/meta-qt5/qtcreator/commits/b4.5.1
+# 4.5.1.meta-qt5.2
SRC_URI = " \
http://download.qt.io/official_releases/qtcreator/4.5/${PV}/qt-creator-opensource-src-${PV}.tar.gz \
file://0001-Fix-Allow-qt-creator-to-build-on-arm-aarch32-and-aar.patch \
- file://botan-non-x86.patch \
- file://linguisttool.patch \
+ file://0002-Use-correct-path-prefix.patch \
+ file://0003-botan-check-for-i386-x86_64.patch \
file://qtcreator.desktop.in \
"
-SRC_URI_append_libc-musl = " file://0002-Link-with-libexecinfo-on-musl.patch"
+SRC_URI_append_libc-musl = " file://0004-Link-with-libexecinfo-on-musl.patch"
SRC_URI[md5sum] = "bd7fdbcdfa84df1171fb28174353e57f"
SRC_URI[sha256sum] = "5fdfc8f05694e37162f208616627262c9971749d6958d8881d62933b3b53e909"