aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-08-24 07:32:09 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2018-09-19 09:55:34 +0000
commit189dd8ab10cace73f46fab8e22bf930b1f6aa5d8 (patch)
treeb0861f63498d5ce4b53d33ee7a055049d15c0838
parent85e665b15864a696a33ceb8cdbb42c5f902201a4 (diff)
qt5-creator: Fix building botan for all non-x86 arches
The original fix was just for x86/x86_64 Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-qt/qt5/qt5-creator/botan-non-x86.patch19
-rw-r--r--recipes-qt/qt5/qt5-creator_4.5.1.bb1
2 files changed, 20 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qt5-creator/botan-non-x86.patch b/recipes-qt/qt5/qt5-creator/botan-non-x86.patch
new file mode 100644
index 00000000..5c83340c
--- /dev/null
+++ b/recipes-qt/qt5/qt5-creator/botan-non-x86.patch
@@ -0,0 +1,19 @@
+Just check for x86 or x86_64 to define X86 based support
+This makes sure it compiles for non-x86 platforms
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Index: qt-creator-opensource-src-4.5.1/src/libs/3rdparty/botan/botan.h
+===================================================================
+--- qt-creator-opensource-src-4.5.1.orig/src/libs/3rdparty/botan/botan.h
++++ qt-creator-opensource-src-4.5.1/src/libs/3rdparty/botan/botan.h
+@@ -85,7 +85,7 @@
+ #endif
+
+ #define BOTAN_TARGET_CPU_IS_LITTLE_ENDIAN
+-#if !defined(__arm__) && !defined(__aarch64__)
++#if defined(__i386__) || defined(__x86_64__)
+ #define BOTAN_TARGET_CPU_IS_X86_FAMILY
+ #endif
+ #define BOTAN_TARGET_UNALIGNED_MEMORY_ACCESS_OK 1
diff --git a/recipes-qt/qt5/qt5-creator_4.5.1.bb b/recipes-qt/qt5/qt5-creator_4.5.1.bb
index c56fcd10..6eaf785f 100644
--- a/recipes-qt/qt5/qt5-creator_4.5.1.bb
+++ b/recipes-qt/qt5/qt5-creator_4.5.1.bb
@@ -22,6 +22,7 @@ DEPENDS_append_libc-musl = " libexecinfo"
SRC_URI = " \
http://download.qt.io/official_releases/qtcreator/4.5/${PV}/qt-creator-opensource-src-${PV}.tar.gz \
file://0001-Fix-Allow-qt-creator-to-build-on-arm-aarch32-and-aar.patch \
+ file://botan-non-x86.patch \
file://qtcreator.desktop.in \
"
SRC_URI_append_libc-musl = " file://0002-Link-with-libexecinfo-on-musl.patch"