aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-08-23 03:01:37 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2018-09-19 09:55:34 +0000
commit66a9704223e327d2f89093367a7967f3efc994e6 (patch)
tree1873b43ebdfb71558557186f842c2e4d47c9857c
parentedf1e434942d3169c459eedaf1d7736ab51ac07a (diff)
qtscript: Fix build on musl
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-qt/qt5/qtscript/0001-Include-asm-sgidefs.h-on-non-glibc-systems.patch36
-rw-r--r--recipes-qt/qt5/qtscript_git.bb4
2 files changed, 39 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qtscript/0001-Include-asm-sgidefs.h-on-non-glibc-systems.patch b/recipes-qt/qt5/qtscript/0001-Include-asm-sgidefs.h-on-non-glibc-systems.patch
new file mode 100644
index 00000000..40dfa97b
--- /dev/null
+++ b/recipes-qt/qt5/qtscript/0001-Include-asm-sgidefs.h-on-non-glibc-systems.patch
@@ -0,0 +1,36 @@
+From c10293d932c63b36eac8a1e18756068f218a044a Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Thu, 23 Aug 2018 02:58:14 +0000
+Subject: [PATCH] Include asm/sgidefs.h on non-glibc systems
+
+sgidefs.h wrapper is glibc specific and causes build
+failures on musl
+
+Fixes
+Platform.h:380:10: fatal error: sgidefs.h: No such file or directory
+ #include <sgidefs.h>
+ ^~~~~~~~~~~
+compilation terminated.
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/3rdparty/javascriptcore/JavaScriptCore/wtf/Platform.h | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/src/3rdparty/javascriptcore/JavaScriptCore/wtf/Platform.h b/src/3rdparty/javascriptcore/JavaScriptCore/wtf/Platform.h
+index 00caa6d..485ec25 100644
+--- a/src/3rdparty/javascriptcore/JavaScriptCore/wtf/Platform.h
++++ b/src/3rdparty/javascriptcore/JavaScriptCore/wtf/Platform.h
+@@ -377,7 +377,11 @@
+
+ #if (defined(mips) || defined(__mips__) || defined(MIPS) || defined(_MIPS_))
+ #define WTF_CPU_MIPS 1
++#if defined(__GLIBC__)
+ #include <sgidefs.h>
++#else
++#include <asm/sgidefs.h>
++#endif
+ #if defined(__MIPSEB__)
+ #define WTF_CPU_BIG_ENDIAN 1
+ #endif
diff --git a/recipes-qt/qt5/qtscript_git.bb b/recipes-qt/qt5/qtscript_git.bb
index 4f18ffd0..17ee1130 100644
--- a/recipes-qt/qt5/qtscript_git.bb
+++ b/recipes-qt/qt5/qtscript_git.bb
@@ -11,7 +11,9 @@ LIC_FILES_CHKSUM = " \
file://LICENSE.LGPL3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
"
-SRC_URI += "file://0001-3rdparty-javascriptcore-Add-RISC-V-support.patch"
+SRC_URI += "file://0001-3rdparty-javascriptcore-Add-RISC-V-support.patch \
+ file://0001-Include-asm-sgidefs.h-on-non-glibc-systems.patch \
+ "
# qemuarm build fails with:
# /OE/build/oe-core/tmp-glibc/work/armv5te-oe-linux-gnueabi/qtscript/5.4.1+gitAUTOINC+822df36f25-r0/git/src/3rdparty/javascriptcore/JavaScriptCore/assembler/AssemblerBuffer.h: In member function 'void QTJSC::AssemblerBuffer::putInt64Unchecked(int64_t)':