aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2019-11-21 12:11:19 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2020-03-13 08:27:29 +0100
commit3efe4ea8b033f433b512ccf2cb90006a65c75834 (patch)
treec5a91e5c76c016637a5a93224afddf9eb4166164
parente6fb3850d43f857e87f7c53fc7df5933fef98cbd (diff)
qt5: upgrade to Qt 5.9.9
Additionally, update recipes with relevant diff from Qt Company maintained meta-qt5 (5.9) layer. It has few commits & some upstream content merge based changes never upstreamed for one reason or another (license alterations & other minor things). Signed-off-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qt3d_git.bb2
-rw-r--r--recipes-qt/qt5/qt5-git.inc2
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qtcanvas3d_git.bb2
-rw-r--r--recipes-qt/qt5/qtcharts_git.bb2
-rw-r--r--recipes-qt/qt5/qtconnectivity_git.bb2
-rw-r--r--recipes-qt/qt5/qtdatavis3d_git.bb2
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb2
-rw-r--r--recipes-qt/qt5/qtgamepad_git.bb2
-rw-r--r--recipes-qt/qt5/qtgraphicaleffects_git.bb2
-rw-r--r--recipes-qt/qt5/qtimageformats_git.bb2
-rw-r--r--recipes-qt/qt5/qtlocation_git.bb2
-rw-r--r--recipes-qt/qt5/qtmultimedia_git.bb2
-rw-r--r--recipes-qt/qt5/qtnetworkauth_git.bb2
-rw-r--r--recipes-qt/qt5/qtquickcontrols2_git.bb2
-rw-r--r--recipes-qt/qt5/qtquickcontrols_git.bb4
-rw-r--r--recipes-qt/qt5/qtremoteobjects_git.bb2
-rw-r--r--recipes-qt/qt5/qtscript_git.bb2
-rw-r--r--recipes-qt/qt5/qtscxml_git.bb2
-rw-r--r--recipes-qt/qt5/qtsensors_git.bb2
-rw-r--r--recipes-qt/qt5/qtserialbus_git.bb2
-rw-r--r--recipes-qt/qt5/qtserialport_git.bb4
-rw-r--r--recipes-qt/qt5/qtsvg_git.bb2
-rw-r--r--recipes-qt/qt5/qttools_git.bb2
-rw-r--r--recipes-qt/qt5/qttranslations_git.bb2
-rw-r--r--recipes-qt/qt5/qtvirtualkeyboard_git.bb2
-rw-r--r--recipes-qt/qt5/qtwayland/0001-fix-build-without-xkbcommon-evdev.patch68
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb9
-rw-r--r--recipes-qt/qt5/qtwebchannel_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb5
-rw-r--r--recipes-qt/qt5/qtwebsockets_git.bb4
-rw-r--r--recipes-qt/qt5/qtwebview_git.bb2
-rw-r--r--recipes-qt/qt5/qtx11extras_git.bb2
-rw-r--r--recipes-qt/qt5/qtxmlpatterns_git.bb2
36 files changed, 38 insertions, 116 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 03151fbb..d79c2540 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -200,4 +200,4 @@ fakeroot do_generate_qt_environment_file() {
addtask generate_qt_environment_file after do_install before do_package
-SRCREV = "82eb6aa08e5dc8a57402b69b4e55ce7d2371e84b"
+SRCREV = "86b933c430eafcaa90f1e56b91a62d3c6c228e5e"
diff --git a/recipes-qt/qt5/qt3d_git.bb b/recipes-qt/qt5/qt3d_git.bb
index 6ff2e33e..81d4125e 100644
--- a/recipes-qt/qt5/qt3d_git.bb
+++ b/recipes-qt/qt5/qt3d_git.bb
@@ -37,6 +37,6 @@ do_configure_prepend() {
${S}/src/quick3d/imports/input/importsinput.pro
}
-SRCREV = "0d923f9fc31fe55006b5e72539bd20ec016ca856"
+SRCREV = "fbd82f24d75ab4f49bb93fa70635dc9c9c989607"
BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-qt/qt5/qt5-git.inc b/recipes-qt/qt5/qt5-git.inc
index 262f62c4..2e7e2389 100644
--- a/recipes-qt/qt5/qt5-git.inc
+++ b/recipes-qt/qt5/qt5-git.inc
@@ -14,4 +14,4 @@ CVE_PRODUCT = "qt"
S = "${WORKDIR}/git"
-PV = "5.9.8+git${SRCPV}"
+PV = "5.9.9+git${SRCPV}"
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index 50aaab8d..1f5c4401 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -125,4 +125,4 @@ do_install() {
echo 'set(_qt5_corelib_extra_includes "${_qt5Core_install_prefix}/lib${QT_DIR_NAME}/mkspecs/linux-oe-g++")' > ${D}${libdir}/cmake/Qt5Core/Qt5CoreConfigExtrasMkspecDir.cmake
}
-SRCREV = "82eb6aa08e5dc8a57402b69b4e55ce7d2371e84b"
+SRCREV = "86b933c430eafcaa90f1e56b91a62d3c6c228e5e"
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index dae5822c..2a453b54 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -220,4 +220,4 @@ INSANE_SKIP_${PN}-mkspecs += "file-rdeps"
RRECOMMENDS_${PN}-plugins += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11-locale', '', d)}"
-SRCREV = "82eb6aa08e5dc8a57402b69b4e55ce7d2371e84b"
+SRCREV = "86b933c430eafcaa90f1e56b91a62d3c6c228e5e"
diff --git a/recipes-qt/qt5/qtcanvas3d_git.bb b/recipes-qt/qt5/qtcanvas3d_git.bb
index 647a7e51..d6be4a41 100644
--- a/recipes-qt/qt5/qtcanvas3d_git.bb
+++ b/recipes-qt/qt5/qtcanvas3d_git.bb
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS = "qtdeclarative"
-SRCREV = "2097038d94301c0a1e684c939d29bc24620ce3c4"
+SRCREV = "5b6e9665c843d9204fecedecf3a1ca587868cd48"
diff --git a/recipes-qt/qt5/qtcharts_git.bb b/recipes-qt/qt5/qtcharts_git.bb
index 98c06718..316a3ed5 100644
--- a/recipes-qt/qt5/qtcharts_git.bb
+++ b/recipes-qt/qt5/qtcharts_git.bb
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative qtmultimedia"
-SRCREV = "ff7e0b5106a847541e13decfd8cbc57985d001b7"
+SRCREV = "d19228381166b1daf1d79dd48ca43304481746d3"
# The same issue as in qtbase:
# http://errors.yoctoproject.org/Errors/Details/152641/
diff --git a/recipes-qt/qt5/qtconnectivity_git.bb b/recipes-qt/qt5/qtconnectivity_git.bb
index 3fb5696d..961aeeba 100644
--- a/recipes-qt/qt5/qtconnectivity_git.bb
+++ b/recipes-qt/qt5/qtconnectivity_git.bb
@@ -19,4 +19,4 @@ PACKAGECONFIG[bluez] = "-feature-bluez,-no-feature-bluez,${BLUEZ}"
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "cd4b17113017df0f9811aa2bd2add37a475a667f"
+SRCREV = "cdc53324e00e4f648891106253c42143b5afeeec"
diff --git a/recipes-qt/qt5/qtdatavis3d_git.bb b/recipes-qt/qt5/qtdatavis3d_git.bb
index 324145d6..b2eb7ce9 100644
--- a/recipes-qt/qt5/qtdatavis3d_git.bb
+++ b/recipes-qt/qt5/qtdatavis3d_git.bb
@@ -8,4 +8,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative qtmultimedia qtxmlpatterns"
-SRCREV = "243106a56ff681ffefcf65af8ecd30fc14181200"
+SRCREV = "5a09643383db7bb3c7acab63b4cbbda46877ccf0"
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index d8ba657b..1a40b233 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -30,6 +30,6 @@ do_install_append_class-nativesdk() {
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtxmlpatterns', 'CONFIG+=OE_QTXMLPATTERNS_ENABLED', '', d)}"
-SRCREV = "145485bec922e9fb062e2b286916c98385e2e84d"
+SRCREV = "9dc3e7885dff7d7b0bccef191ca58504e3771a12"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtgamepad_git.bb b/recipes-qt/qt5/qtgamepad_git.bb
index 088e7cd5..2623d50d 100644
--- a/recipes-qt/qt5/qtgamepad_git.bb
+++ b/recipes-qt/qt5/qtgamepad_git.bb
@@ -14,4 +14,4 @@ PACKAGECONFIG[sdl2] = "-feature-sdl2,-no-feature-sdl2,libsdl2"
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "6f1dca6e8b183a42c7a428645196a9d305602077"
+SRCREV = "15dcf7b0e1ffe68f40cd06fdb7c01e0b63913dd9"
diff --git a/recipes-qt/qt5/qtgraphicaleffects_git.bb b/recipes-qt/qt5/qtgraphicaleffects_git.bb
index d802328e..9e01d5fd 100644
--- a/recipes-qt/qt5/qtgraphicaleffects_git.bb
+++ b/recipes-qt/qt5/qtgraphicaleffects_git.bb
@@ -18,4 +18,4 @@ RDEPENDS_${PN}-dev = ""
# http://errors.yoctoproject.org/Errors/Build/44912/
LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
-SRCREV = "718e1e1f376ef990b998aa72e2029085e6b455be"
+SRCREV = "3da844bf29607c6b92faa5ebb641cb1f5fe62876"
diff --git a/recipes-qt/qt5/qtimageformats_git.bb b/recipes-qt/qt5/qtimageformats_git.bb
index 3322908c..77d43918 100644
--- a/recipes-qt/qt5/qtimageformats_git.bb
+++ b/recipes-qt/qt5/qtimageformats_git.bb
@@ -26,4 +26,4 @@ PACKAGECONFIG[libwebp] = ",CONFIG+=done_config_libwebp,libwebp"
EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "50f78099ca9add9ba9ea5a3e464c864d5a98aee3"
+SRCREV = "2ea8273518468708735c09d5ea2cafda55f4b072"
diff --git a/recipes-qt/qt5/qtlocation_git.bb b/recipes-qt/qt5/qtlocation_git.bb
index 35e56d46..5b440feb 100644
--- a/recipes-qt/qt5/qtlocation_git.bb
+++ b/recipes-qt/qt5/qtlocation_git.bb
@@ -29,7 +29,7 @@ SRC_URI += " \
${QT_GIT}/qtlocation-mapboxgl.git;name=qtlocation-mapboxgl;branch=upstream/qt-staging;protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/mapbox-gl-native \
"
-SRCREV_qtlocation = "3696006091d0536270c5f8499b19be12e54d841f"
+SRCREV_qtlocation = "95d75d7712e76f286753a1bb64f7b0987ff42c66"
SRCREV_qtlocation-mapboxgl = "8c1be4ec01ef46bf453856531ebf53b48ce3dbe7"
SRCREV_FORMAT = "qtlocation_qtlocation-mapboxgl"
diff --git a/recipes-qt/qt5/qtmultimedia_git.bb b/recipes-qt/qt5/qtmultimedia_git.bb
index d5356ff3..4d0e0b13 100644
--- a/recipes-qt/qt5/qtmultimedia_git.bb
+++ b/recipes-qt/qt5/qtmultimedia_git.bb
@@ -35,4 +35,4 @@ SRC_URI += "\
# http://errors.yoctoproject.org/Errors/Build/44914/
LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
-SRCREV = "b0df68530506e2b3b17365f07711d80dda6ff44c"
+SRCREV = "2320aa69a67ecbf4d7ec3b5ad4be44e29042389f"
diff --git a/recipes-qt/qt5/qtnetworkauth_git.bb b/recipes-qt/qt5/qtnetworkauth_git.bb
index b9f74626..eb8ceee2 100644
--- a/recipes-qt/qt5/qtnetworkauth_git.bb
+++ b/recipes-qt/qt5/qtnetworkauth_git.bb
@@ -9,4 +9,4 @@ require qt5-git.inc
DEPENDS += "qtbase"
-SRCREV = "00a49f18f66219730af26dd23899b6d8ed9f9e76"
+SRCREV = "e6ca764e35a27d05dec5ebcddc60d82c2feafe05"
diff --git a/recipes-qt/qt5/qtquickcontrols2_git.bb b/recipes-qt/qt5/qtquickcontrols2_git.bb
index 3da0cada..664a27a9 100644
--- a/recipes-qt/qt5/qtquickcontrols2_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols2_git.bb
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtdeclarative"
-SRCREV = "1ef144bf3a324ac4bdea092a0b845cb483ec9a1d"
+SRCREV = "b1e0bb1efdec91e1f199a16d0a87685558a536b9"
diff --git a/recipes-qt/qt5/qtquickcontrols_git.bb b/recipes-qt/qt5/qtquickcontrols_git.bb
index 083f98a5..e2de7816 100644
--- a/recipes-qt/qt5/qtquickcontrols_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols_git.bb
@@ -12,11 +12,9 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtdeclarative"
-RDEPENDS_${PN}-dev = ""
-
FILES_${PN}-qmlplugins += " \
${OE_QMAKE_PATH_QML}/QtQuick/Controls/Shaders \
${OE_QMAKE_PATH_QML}/QtQuick/Dialogs/qml/icons.ttf \
"
-SRCREV = "8c3b97959cb2c157102994082dd2ba0e1985ced7"
+SRCREV = "7f3dddae7a5be9e4c80c0683ff49c2b19a9c3f30"
diff --git a/recipes-qt/qt5/qtremoteobjects_git.bb b/recipes-qt/qt5/qtremoteobjects_git.bb
index a55a8ad0..bf3f0265 100644
--- a/recipes-qt/qt5/qtremoteobjects_git.bb
+++ b/recipes-qt/qt5/qtremoteobjects_git.bb
@@ -24,6 +24,6 @@ PACKAGECONFIG[tools-only] = "CONFIG+=tools-only"
EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "b78f04561775639f79bea7acca3b6591515e2af1"
+SRCREV = "b719c932b507de5d88a42d698e72c22330905ca9"
BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-qt/qt5/qtscript_git.bb b/recipes-qt/qt5/qtscript_git.bb
index 89f3c039..57d79e28 100644
--- a/recipes-qt/qt5/qtscript_git.bb
+++ b/recipes-qt/qt5/qtscript_git.bb
@@ -29,4 +29,4 @@ DEPENDS += "qtbase"
# http://errors.yoctoproject.org/Errors/Build/44915/
LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
-SRCREV = "4fe24b5f0d104976f361fd03e5398730bccc4c98"
+SRCREV = "7cbed907410d4a2baa605a9075a4313b8009d616"
diff --git a/recipes-qt/qt5/qtscxml_git.bb b/recipes-qt/qt5/qtscxml_git.bb
index fe23f04b..d7bfa460 100644
--- a/recipes-qt/qt5/qtscxml_git.bb
+++ b/recipes-qt/qt5/qtscxml_git.bb
@@ -10,7 +10,7 @@ require qt5-git.inc
DEPENDS += "qtbase qtdeclarative qtxmlpatterns qtscxml-native"
-SRCREV = "f3448b881740eb72befe229999bd5bc8b48908ee"
+SRCREV = "c812d2703934e976970b5bb54d9a213711a92c06"
# Patches from https://github.com/meta-qt5/qtscxml/commits/b5.9
# 5.9.meta-qt5.8
diff --git a/recipes-qt/qt5/qtsensors_git.bb b/recipes-qt/qt5/qtsensors_git.bb
index ee36a60e..35baaf7d 100644
--- a/recipes-qt/qt5/qtsensors_git.bb
+++ b/recipes-qt/qt5/qtsensors_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "247c06da51ee9cf7a91c01ae3b013690f9ab7809"
+SRCREV = "0fc90f5a50511de451142b6baf3bd89d8d65fd00"
diff --git a/recipes-qt/qt5/qtserialbus_git.bb b/recipes-qt/qt5/qtserialbus_git.bb
index 0da673a5..a7a85826 100644
--- a/recipes-qt/qt5/qtserialbus_git.bb
+++ b/recipes-qt/qt5/qtserialbus_git.bb
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtserialport"
-SRCREV = "fdc716e10ac630416c04275640daaa65d6c92dd8"
+SRCREV = "9c806437bfa09cf36f4f3dac9c7317333809e9ae"
diff --git a/recipes-qt/qt5/qtserialport_git.bb b/recipes-qt/qt5/qtserialport_git.bb
index 48180a0d..fb63c278 100644
--- a/recipes-qt/qt5/qtserialport_git.bb
+++ b/recipes-qt/qt5/qtserialport_git.bb
@@ -3,7 +3,7 @@ require qt5-git.inc
# text of LGPL_EXCEPTION.txt and LICENSE.FDL is slightly different than what
# other qt* components use :/
-LICENSE = "GFDL-1.3 & BSD & (LGPL-2.1 & The-Qt-Company-Qt-LGPL-Exception-1.1 | LGPL-3.0) | The-Qt-Company-Commercial"
+LICENSE = "GFDL-1.3 & BSD & ( GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial ) & ( GPL-2.0+ | LGPL-3.0 | The-Qt-Company-Commercial )"
LIC_FILES_CHKSUM = " \
file://LICENSE.LGPL3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504 \
@@ -15,4 +15,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "a5b4f0511006bfa4999beb0df094e11d25a4e6eb"
+SRCREV = "7f417bb3ae2d2df57f6240febb50ac00ff95e947"
diff --git a/recipes-qt/qt5/qtsvg_git.bb b/recipes-qt/qt5/qtsvg_git.bb
index cf5280e8..34a82aa4 100644
--- a/recipes-qt/qt5/qtsvg_git.bb
+++ b/recipes-qt/qt5/qtsvg_git.bb
@@ -13,4 +13,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "44de875f059c35c4819f331a2fae1ab52c81c62c"
+SRCREV = "6025be8593c35d8d78cb93b518d6e9ca7f21b607"
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb
index 7139499d..568a2226 100644
--- a/recipes-qt/qt5/qttools_git.bb
+++ b/recipes-qt/qt5/qttools_git.bb
@@ -29,7 +29,7 @@ PACKAGECONFIG[qtwebkit] = ",,qtwebkit"
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtwebkit', '', 'CONFIG+=noqtwebkit', d)}"
-SRCREV = "cb4fb7bdd59bb57324893cf1b226f380d03b574f"
+SRCREV = "01899896acdba9ccda10a84610fc53e445a02c61"
BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-qt/qt5/qttranslations_git.bb b/recipes-qt/qt5/qttranslations_git.bb
index 24938790..207d716f 100644
--- a/recipes-qt/qt5/qttranslations_git.bb
+++ b/recipes-qt/qt5/qttranslations_git.bb
@@ -106,4 +106,4 @@ FILES_${PN}-qt = " \
${OE_QMAKE_PATH_TRANSLATIONS}/qt_*.qm \
"
-SRCREV = "caf6bbc354e63edb4f9f851963785a9f2b23312b"
+SRCREV = "1c34d7807f67507bf9f2e169a6f58b35109f1355"
diff --git a/recipes-qt/qt5/qtvirtualkeyboard_git.bb b/recipes-qt/qt5/qtvirtualkeyboard_git.bb
index 23bbfca8..b8b1c4fd 100644
--- a/recipes-qt/qt5/qtvirtualkeyboard_git.bb
+++ b/recipes-qt/qt5/qtvirtualkeyboard_git.bb
@@ -53,4 +53,4 @@ FILES_${PN} += "${OE_QMAKE_PATH_DATA}/qtvirtualkeyboard/lipi_toolkit"
DEPENDS += "qtbase qtdeclarative qtmultimedia qtquickcontrols qtsvg qtxmlpatterns"
-SRCREV = "dc18b608b5267ef7bce854aff6803a98137f43d2"
+SRCREV = "744800d95e25a25bd43c4858d16d41f03933803c"
diff --git a/recipes-qt/qt5/qtwayland/0001-fix-build-without-xkbcommon-evdev.patch b/recipes-qt/qt5/qtwayland/0001-fix-build-without-xkbcommon-evdev.patch
deleted file mode 100644
index debca547..00000000
--- a/recipes-qt/qt5/qtwayland/0001-fix-build-without-xkbcommon-evdev.patch
+++ /dev/null
@@ -1,68 +0,0 @@
-From 3c7bf618ca67f8f31af425ba59ea87005d6ed0ea Mon Sep 17 00:00:00 2001
-From: Raphael Freudiger <laser_b@gmx.ch>
-Date: Tue, 10 Jan 2017 15:49:55 +0100
-Subject: [PATCH] fix build without xkbcommon-evdev
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Change-Id: I4f52c4ad741fdd7063a18b67f5777b52f03726fe
-Signed-off-by: Raphael Freudiger <laser_b@gmx.ch>
-Signed-off-by: Gordan Markuš <gordan.markus@pelagicore.com>
----
- src/client/client.pro | 2 ++
- src/compositor/compositor.pro | 2 ++
- src/compositor/compositor_api/qwaylandkeyboard.cpp | 13 +++++++------
- 3 files changed, 11 insertions(+), 6 deletions(-)
-
-diff --git a/src/client/client.pro b/src/client/client.pro
-index eae7ad52..0bb7b188 100644
---- a/src/client/client.pro
-+++ b/src/client/client.pro
-@@ -147,3 +147,5 @@ MODULE_PLUGIN_TYPES = \
- wayland-decoration-client \
- wayland-shell-integration
- load(qt_module)
-+
-+LIBS += -lxkbcommon
-diff --git a/src/compositor/compositor.pro b/src/compositor/compositor.pro
-index dc9000d9..4eebfd64 100644
---- a/src/compositor/compositor.pro
-+++ b/src/compositor/compositor.pro
-@@ -32,3 +32,5 @@ include ($$PWD/extensions/extensions.pri)
- MODULE_PLUGIN_TYPES = \
- wayland-graphics-integration-server
- load(qt_module)
-+
-+LIBS += -lxkbcommon
-diff --git a/src/compositor/compositor_api/qwaylandkeyboard.cpp b/src/compositor/compositor_api/qwaylandkeyboard.cpp
-index c30f7b18..e6f1a0b3 100644
---- a/src/compositor/compositor_api/qwaylandkeyboard.cpp
-+++ b/src/compositor/compositor_api/qwaylandkeyboard.cpp
-@@ -349,12 +349,6 @@ void QWaylandKeyboardPrivate::createXKBState(xkb_keymap *keymap)
- xkb_state = xkb_state_new(keymap);
- }
-
--uint QWaylandKeyboardPrivate::toWaylandXkbV1Key(const uint nativeScanCode)
--{
-- const uint offset = 8;
-- Q_ASSERT(nativeScanCode >= offset);
-- return nativeScanCode - offset;
--}
-
- void QWaylandKeyboardPrivate::createXKBKeymap()
- {
-@@ -384,6 +378,13 @@ void QWaylandKeyboardPrivate::createXKBKeymap()
- }
- #endif
-
-+uint QWaylandKeyboardPrivate::toWaylandXkbV1Key(const uint nativeScanCode)
-+{
-+ const uint offset = 8;
-+ Q_ASSERT(nativeScanCode >= offset);
-+ return nativeScanCode - offset;
-+}
-+
- void QWaylandKeyboardPrivate::sendRepeatInfo()
- {
- Q_FOREACH (Resource *resource, resourceMap()) {
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index 4e542cca..aa7ee025 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -37,14 +37,7 @@ PACKAGECONFIG[libhybris-egl-server] = "-feature-libhybris-egl-server,-no-feature
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "79ec94d0efbeabe485275e5c79c828aa64641afa"
-
-# Patches from https://github.com/meta-qt5/qtwayland/commits/b5.9
-# 5.9.meta-qt5.8
-# From https://bugreports.qt.io/browse/QTBUG-57767
-SRC_URI += " \
- file://0001-fix-build-without-xkbcommon-evdev.patch \
-"
+SRCREV = "5e689968cefeb78f9b55719ec3ef83ba705b348a"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtwebchannel_git.bb b/recipes-qt/qt5/qtwebchannel_git.bb
index 9b02e0d5..16972444 100644
--- a/recipes-qt/qt5/qtwebchannel_git.bb
+++ b/recipes-qt/qt5/qtwebchannel_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtdeclarative qtwebsockets"
-SRCREV = "e23e37189fb78cb090c67fd01b187b7a59aa8c77"
+SRCREV = "861536106129ca781b476c9071c5fc47ce585845"
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 37fab0bf..de06e1e7 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -25,7 +25,6 @@ DEPENDS += " \
${@bb.utils.contains('DISTRO_FEATURES', 'alsa', 'alsa-lib', '', d)} \
"
-DEPENDS += "yasm-native"
DEPENDS_append_libc-musl = " libexecinfo"
EXTRA_QMAKEVARS_PRE += "GYP_CONFIG+=use_system_yasm \
@@ -164,8 +163,8 @@ SRC_URI_append_libc-musl = "\
file://0016-chromium-musl-tcmalloc-Use-off64_t-insread-of-__off6.patch;patchdir=src/3rdparty \
"
-SRCREV_qtwebengine = "86f8a0dfa47fea0ba41c386a9753db94d8de3b54"
-SRCREV_chromium = "45ed09101724148401a193e20e3545c8f3de4df2"
+SRCREV_qtwebengine = "745ad675fdd434cd34346909ebe9172881750c60"
+SRCREV_chromium = "0ee076e7a6507637efad493edc367fd63b7e7fb1"
SRCREV = "${SRCREV_qtwebengine}"
SRCREV_FORMAT = "qtwebengine_chromium"
diff --git a/recipes-qt/qt5/qtwebsockets_git.bb b/recipes-qt/qt5/qtwebsockets_git.bb
index e61f8862..0418b297 100644
--- a/recipes-qt/qt5/qtwebsockets_git.bb
+++ b/recipes-qt/qt5/qtwebsockets_git.bb
@@ -1,7 +1,7 @@
require qt5.inc
require qt5-git.inc
-LICENSE = "GFDL-1.3 & (GPL-3 | LGPL-3.0)"
+LICENSE = "GFDL-1.3 & (GPL-3 | LGPL-3.0) | The-Qt-Company-Commercial"
LIC_FILES_CHKSUM = " \
file://LICENSE.GPL2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504 \
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "b5d8a09e573ae5c194a962e84a31ef3251250258"
+SRCREV = "64a63c2eacbe71744006515d6d4c7b223439e727"
diff --git a/recipes-qt/qt5/qtwebview_git.bb b/recipes-qt/qt5/qtwebview_git.bb
index 24298f80..023db6ce 100644
--- a/recipes-qt/qt5/qtwebview_git.bb
+++ b/recipes-qt/qt5/qtwebview_git.bb
@@ -19,4 +19,4 @@ COMPATIBLE_MACHINE_armv7a = "(.*)"
COMPATIBLE_MACHINE_armv7ve = "(.*)"
COMPATIBLE_MACHINE_aarch64 = "(.*)"
-SRCREV = "6ea20e8930b02928a20173c1718ba5efd7b24dec"
+SRCREV = "b50a71aa17074d082849af34903ee9bb18166717"
diff --git a/recipes-qt/qt5/qtx11extras_git.bb b/recipes-qt/qt5/qtx11extras_git.bb
index d3bbba28..ac853b35 100644
--- a/recipes-qt/qt5/qtx11extras_git.bb
+++ b/recipes-qt/qt5/qtx11extras_git.bb
@@ -13,4 +13,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "078fef443e40b99098dc5a035ae6e4072682cdbe"
+SRCREV = "4f6e6fa9eb2a6d60bda62f6595e8f1edfa9380d2"
diff --git a/recipes-qt/qt5/qtxmlpatterns_git.bb b/recipes-qt/qt5/qtxmlpatterns_git.bb
index 900d0886..7bf379a8 100644
--- a/recipes-qt/qt5/qtxmlpatterns_git.bb
+++ b/recipes-qt/qt5/qtxmlpatterns_git.bb
@@ -15,6 +15,6 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "03d89c93e98af5fe3341c4d634dfe675c2fefefa"
+SRCREV = "e7bf7b0986a4d3122177139894c13fbcc0231018"
BBCLASSEXTEND =+ "native nativesdk"