aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2017-01-10 15:38:39 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2017-01-10 14:27:33 +0000
commit2c3f5e50233b30c1ab778b47cc8c57a9e7e10c3e (patch)
tree0cf6634e35bb7d044c47a61e13ad86e96b73486c
parent7d9f1f7984e3f6b0521e76a390f2456c674e6ea0 (diff)
qtscxml: patch cmake files to work with external host bin paths
Using the same approach as with cmake files in qtbase. Change-Id: I8d74eb2c7456a648e17e07a271499f1b0b01c637 Reviewed-by: Volker Krause <volker.krause@kdab.com>
-rw-r--r--recipes-qt/qt5/qtscxml/0001-Use-external-host-bin-path-for-cmake-file.patch28
-rw-r--r--recipes-qt/qt5/qtscxml_git.bb2
2 files changed, 30 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtscxml/0001-Use-external-host-bin-path-for-cmake-file.patch b/recipes-qt/qt5/qtscxml/0001-Use-external-host-bin-path-for-cmake-file.patch
new file mode 100644
index 00000000..0b90a66b
--- /dev/null
+++ b/recipes-qt/qt5/qtscxml/0001-Use-external-host-bin-path-for-cmake-file.patch
@@ -0,0 +1,28 @@
+From 210049f0e53f7fb8e5c44325b13947add9618f89 Mon Sep 17 00:00:00 2001
+From: Samuli Piippo <samuli.piippo@qt.io>
+Date: Tue, 10 Jan 2017 15:28:26 +0200
+Subject: [PATCH] Use external host bin path for cmake file
+
+Need to use ${OE_QMAKE_PATH_EXTERNAL_HOST_BINS} for cmake to find the
+qscxmlc tool from correct sysroot path.
+
+Upstream-Status: Inappropriate [OE specific]
+Signed-off-by: Samuli Piippo <samuli.piippo@qt.io>
+Change-Id: Idb814be705e9cbaad7f1e68b5d7cdb79c4b65008
+---
+ src/scxml/Qt5ScxmlConfigExtras.cmake.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/scxml/Qt5ScxmlConfigExtras.cmake.in b/src/scxml/Qt5ScxmlConfigExtras.cmake.in
+index edb320a..c2f8be8 100644
+--- a/src/scxml/Qt5ScxmlConfigExtras.cmake.in
++++ b/src/scxml/Qt5ScxmlConfigExtras.cmake.in
+@@ -40,7 +40,7 @@ if (NOT TARGET Qt5::qscxmlc)
+ !!IF isEmpty(CMAKE_BIN_DIR_IS_ABSOLUTE)
+ set(imported_location \"${_qt5Scxml_install_prefix}/$${CMAKE_BIN_DIR}qscxmlc$$CMAKE_BIN_SUFFIX\")
+ !!ELSE
+- set(imported_location \"$${CMAKE_BIN_DIR}qscxmlc$$CMAKE_BIN_SUFFIX\")
++ set(imported_location \"${OE_QMAKE_PATH_EXTERNAL_HOST_BINS}/qscxmlc$$CMAKE_BIN_SUFFIX\")
+ !!ENDIF
+ _qt5_Scxml_check_file_exists(${imported_location})
+
diff --git a/recipes-qt/qt5/qtscxml_git.bb b/recipes-qt/qt5/qtscxml_git.bb
index 8b6d575b..d69d00fe 100644
--- a/recipes-qt/qt5/qtscxml_git.bb
+++ b/recipes-qt/qt5/qtscxml_git.bb
@@ -12,6 +12,8 @@ DEPENDS += "qtbase qtdeclarative qtxmlpatterns qtscxml-native"
SRCREV = "4704292500b98143eee9b0fb0b6a34a858ed1253"
+SRC_URI += "file://0001-Use-external-host-bin-path-for-cmake-file.patch"
+
do_install_append_class-nativesdk() {
# qml files not needed in nativesdk
rm -rf ${D}${OE_QMAKE_PATH_QML}