aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/qmake5_base.bbclass4
-rw-r--r--recipes-qt/qt5/qt3d/0001-Allow-a-tools-only-build.patch1
-rw-r--r--recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch11
-rw-r--r--recipes-qt/qt5/qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qtquickcontrols/0001-texteditor-fix-invalid-use-of-incomplete-type-class-.patch24
-rw-r--r--recipes-qt/qt5/qtquickcontrols_git.bb8
-rw-r--r--recipes-qt/qt5/qtwayland/0001-fix-build-without-xkbcommon-evdev.patch68
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb7
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb1
-rw-r--r--recipes-qt/qt5/qtwebsockets_git.bb2
10 files changed, 9 insertions, 119 deletions
diff --git a/classes/qmake5_base.bbclass b/classes/qmake5_base.bbclass
index 8e1fe206..3bc1279d 100644
--- a/classes/qmake5_base.bbclass
+++ b/classes/qmake5_base.bbclass
@@ -29,7 +29,6 @@ EXTRA_OEMAKE = " \
OE_QMAKE_LDFLAGS='${OE_QMAKE_LDFLAGS}' \
OE_QMAKE_AR='${OE_QMAKE_AR}' \
OE_QMAKE_STRIP='${OE_QMAKE_STRIP}' \
- OE_QMAKE_WAYLAND_SCANNER='${OE_QMAKE_WAYLAND_SCANNER}' \
OE_QMAKE_INCDIR_QT='${STAGING_DIR_TARGET}/${OE_QMAKE_PATH_HEADERS}' \
"
@@ -43,7 +42,6 @@ export OE_QMAKE_LINK = "${CXX}"
export OE_QMAKE_LDFLAGS = "${LDFLAGS}"
export OE_QMAKE_AR = "${AR}"
export OE_QMAKE_STRIP = "echo"
-export OE_QMAKE_WAYLAND_SCANNER = "${STAGING_BINDIR_NATIVE}/wayland-scanner"
# qmake reads if from shell environment
export OE_QMAKE_QTCONF_PATH = "${WORKDIR}/qt.conf"
@@ -88,7 +86,7 @@ generate_qt_config_file_effective_paths() {
[EffectivePaths]
HostBinaries = ${OE_QMAKE_PATH_EXTERNAL_HOST_BINS}
HostData = ${OE_QMAKE_PATH_HOST_DATA}
-HostPrefix = ${STAGING_DIR_NATIVE}${prefix_native}
+HostPrefix = ${STAGING_DIR_NATIVE}
EOF
}
#
diff --git a/recipes-qt/qt5/qt3d/0001-Allow-a-tools-only-build.patch b/recipes-qt/qt5/qt3d/0001-Allow-a-tools-only-build.patch
index a0a95313..2612048a 100644
--- a/recipes-qt/qt5/qt3d/0001-Allow-a-tools-only-build.patch
+++ b/recipes-qt/qt5/qt3d/0001-Allow-a-tools-only-build.patch
@@ -3,6 +3,7 @@ From: Samuli Piippo <samuli.piippo@theqtcompany.com>
Date: Wed, 10 Feb 2016 09:02:09 +0200
Subject: [PATCH] Allow a tools-only build
+Change-Id: I4de6b96ec51fe297a0eeb757cef56d8fb40bd6f0
---
qt3d.pro | 7 ++++++-
src/3rdparty/assimp/assimp_dependency.pri | 2 +-
diff --git a/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch b/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch
index 254eb12a..130c5890 100644
--- a/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch
+++ b/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch
@@ -1,4 +1,4 @@
-From 3e3ba87fc8158a0c11b16f72e931ca3c19eff6d9 Mon Sep 17 00:00:00 2001
+From a77e7c2996ca25cc59b04b165a24575440dd7efa Mon Sep 17 00:00:00 2001
From: Martin Jansa <Martin.Jansa@gmail.com>
Date: Mon, 15 Apr 2013 04:29:32 +0200
Subject: [PATCH] Add linux-oe-g++ platform
@@ -23,9 +23,9 @@ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
configure | 2 +-
mkspecs/features/configure.prf | 4 ++--
mkspecs/features/qt_functions.prf | 2 +-
- mkspecs/linux-oe-g++/qmake.conf | 43 ++++++++++++++++++++++++++++++++++++
+ mkspecs/linux-oe-g++/qmake.conf | 42 ++++++++++++++++++++++++++++++++++++
mkspecs/linux-oe-g++/qplatformdefs.h | 1 +
- 5 files changed, 48 insertions(+), 4 deletions(-)
+ 5 files changed, 47 insertions(+), 4 deletions(-)
create mode 100644 mkspecs/linux-oe-g++/qmake.conf
create mode 100644 mkspecs/linux-oe-g++/qplatformdefs.h
@@ -78,10 +78,10 @@ index 1903e50..c093dd4 100644
cmd = perl -w $$system_path($${cmd}.pl)
diff --git a/mkspecs/linux-oe-g++/qmake.conf b/mkspecs/linux-oe-g++/qmake.conf
new file mode 100644
-index 0000000..c1837e6
+index 0000000..30d31ed
--- /dev/null
+++ b/mkspecs/linux-oe-g++/qmake.conf
-@@ -0,0 +1,43 @@
+@@ -0,0 +1,42 @@
+#
+# qmake configuration for linux-g++ with modifications for building with OpenEmbedded
+#
@@ -95,7 +95,6 @@ index 0000000..c1837e6
+# QMAKE_<TOOL> (moc, uic, rcc) are gone, overwrite only ar and strip
+QMAKE_AR = $$(OE_QMAKE_AR) cqs
+QMAKE_STRIP = $$(OE_QMAKE_STRIP)
-+QMAKE_WAYLAND_SCANNER = $$(OE_QMAKE_WAYLAND_SCANNER)
+
+include(../common/gcc-base-unix.conf)
+
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 0e3a8ace..488a78bd 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -214,7 +214,7 @@ do_install_append() {
touch ${D}/${OE_QMAKE_PATH_QT_ARCHDATA}/mkspecs/oe-device-extra.pri
# Replace host paths with qmake built-in properties
- sed -i -e 's|${STAGING_DIR_NATIVE}${prefix_native}|$$[QT_HOST_PREFIX/get]|g' \
+ sed -i -e 's|${STAGING_DIR_NATIVE}|$$[QT_HOST_PREFIX/get]|g' \
-e 's|${STAGING_DIR_HOST}|$$[QT_SYSROOT]|g' \
${D}/${OE_QMAKE_PATH_QT_ARCHDATA}/mkspecs/*.pri
diff --git a/recipes-qt/qt5/qtquickcontrols/0001-texteditor-fix-invalid-use-of-incomplete-type-class-.patch b/recipes-qt/qt5/qtquickcontrols/0001-texteditor-fix-invalid-use-of-incomplete-type-class-.patch
deleted file mode 100644
index 7e6fb798..00000000
--- a/recipes-qt/qt5/qtquickcontrols/0001-texteditor-fix-invalid-use-of-incomplete-type-class-.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From ae3bedf79b92ab4ce4d14f8738733cbd854f8902 Mon Sep 17 00:00:00 2001
-From: Denys Dmytriyenko <denys@ti.com>
-Date: Thu, 31 Mar 2016 19:57:01 -0400
-Subject: [PATCH] texteditor: fix invalid use of incomplete type 'class QDebug'
-
-Upstream-Status: Pending
-
-Signed-off-by: Denys Dmytriyenko <denys@ti.com>
----
- examples/quickcontrols/controls/texteditor/src/documenthandler.cpp | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/examples/quickcontrols/controls/texteditor/src/documenthandler.cpp b/examples/quickcontrols/controls/texteditor/src/documenthandler.cpp
-index 69da88f..9039191 100644
---- a/examples/quickcontrols/controls/texteditor/src/documenthandler.cpp
-+++ b/examples/quickcontrols/controls/texteditor/src/documenthandler.cpp
-@@ -54,6 +54,7 @@
- #include <QtGui/QTextCursor>
- #include <QtGui/QFontDatabase>
- #include <QtCore/QFileInfo>
-+#include <QtCore/QDebug>
-
- DocumentHandler::DocumentHandler()
- : m_target(0)
diff --git a/recipes-qt/qt5/qtquickcontrols_git.bb b/recipes-qt/qt5/qtquickcontrols_git.bb
index 266e570a..74b70237 100644
--- a/recipes-qt/qt5/qtquickcontrols_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols_git.bb
@@ -15,17 +15,9 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtdeclarative"
-RDEPENDS_${PN}-dev = ""
-
FILES_${PN}-qmlplugins += " \
${OE_QMAKE_PATH_QML}/QtQuick/Controls/Shaders \
${OE_QMAKE_PATH_QML}/QtQuick/Dialogs/qml/icons.ttf \
"
-# Patches from https://github.com/meta-qt5/qtquickcontrols/commits/b5.9
-# 5.9.meta-qt5.4
-SRC_URI += " \
- file://0001-texteditor-fix-invalid-use-of-incomplete-type-class-.patch \
-"
-
SRCREV = "8da20ddef88cb48b7bb09ff7dc1db6517add8e72"
diff --git a/recipes-qt/qt5/qtwayland/0001-fix-build-without-xkbcommon-evdev.patch b/recipes-qt/qt5/qtwayland/0001-fix-build-without-xkbcommon-evdev.patch
deleted file mode 100644
index d44396fc..00000000
--- a/recipes-qt/qt5/qtwayland/0001-fix-build-without-xkbcommon-evdev.patch
+++ /dev/null
@@ -1,68 +0,0 @@
-From 04cab2db5b179f0ff3a223385e7505f9756fbb3c Mon Sep 17 00:00:00 2001
-From: Raphael Freudiger <laser_b@gmx.ch>
-Date: Tue, 10 Jan 2017 15:49:55 +0100
-Subject: [PATCH] fix build without xkbcommon-evdev
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Change-Id: I4f52c4ad741fdd7063a18b67f5777b52f03726fe
-Signed-off-by: Raphael Freudiger <laser_b@gmx.ch>
-Signed-off-by: Gordan Markuš <gordan.markus@pelagicore.com>
----
- src/client/client.pro | 2 ++
- src/compositor/compositor.pro | 2 ++
- src/compositor/compositor_api/qwaylandkeyboard.cpp | 13 +++++++------
- 3 files changed, 11 insertions(+), 6 deletions(-)
-
-diff --git a/src/client/client.pro b/src/client/client.pro
-index eae7ad5..0bb7b18 100644
---- a/src/client/client.pro
-+++ b/src/client/client.pro
-@@ -147,3 +147,5 @@ MODULE_PLUGIN_TYPES = \
- wayland-decoration-client \
- wayland-shell-integration
- load(qt_module)
-+
-+LIBS += -lxkbcommon
-diff --git a/src/compositor/compositor.pro b/src/compositor/compositor.pro
-index dc9000d..4eebfd6 100644
---- a/src/compositor/compositor.pro
-+++ b/src/compositor/compositor.pro
-@@ -32,3 +32,5 @@ include ($$PWD/extensions/extensions.pri)
- MODULE_PLUGIN_TYPES = \
- wayland-graphics-integration-server
- load(qt_module)
-+
-+LIBS += -lxkbcommon
-diff --git a/src/compositor/compositor_api/qwaylandkeyboard.cpp b/src/compositor/compositor_api/qwaylandkeyboard.cpp
-index c30f7b1..e6f1a0b 100644
---- a/src/compositor/compositor_api/qwaylandkeyboard.cpp
-+++ b/src/compositor/compositor_api/qwaylandkeyboard.cpp
-@@ -349,12 +349,6 @@ void QWaylandKeyboardPrivate::createXKBState(xkb_keymap *keymap)
- xkb_state = xkb_state_new(keymap);
- }
-
--uint QWaylandKeyboardPrivate::toWaylandXkbV1Key(const uint nativeScanCode)
--{
-- const uint offset = 8;
-- Q_ASSERT(nativeScanCode >= offset);
-- return nativeScanCode - offset;
--}
-
- void QWaylandKeyboardPrivate::createXKBKeymap()
- {
-@@ -384,6 +378,13 @@ void QWaylandKeyboardPrivate::createXKBKeymap()
- }
- #endif
-
-+uint QWaylandKeyboardPrivate::toWaylandXkbV1Key(const uint nativeScanCode)
-+{
-+ const uint offset = 8;
-+ Q_ASSERT(nativeScanCode >= offset);
-+ return nativeScanCode - offset;
-+}
-+
- void QWaylandKeyboardPrivate::sendRepeatInfo()
- {
- Q_FOREACH (Resource *resource, resourceMap()) {
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index 9466d280..64e91854 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -39,13 +39,6 @@ EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
SRCREV = "83db09bd0acaafb256880e3a217ed9df0641a00a"
-# Patches from https://github.com/meta-qt5/qtwayland/commits/b5.9
-# 5.9.meta-qt5.4
-# From https://bugreports.qt.io/browse/QTBUG-57767
-SRC_URI += " \
- file://0001-fix-build-without-xkbcommon-evdev.patch \
-"
-
BBCLASSEXTEND =+ "native nativesdk"
# The same issue as in qtbase:
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index f299f6e0..bfc942ff 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -25,7 +25,6 @@ DEPENDS += " \
${@bb.utils.contains('DISTRO_FEATURES', 'alsa', 'alsa-lib', '', d)} \
"
-DEPENDS += "yasm-native"
DEPENDS_append_libc-musl = " libexecinfo"
EXTRA_QMAKEVARS_PRE += "GYP_CONFIG+=use_system_yasm \
diff --git a/recipes-qt/qt5/qtwebsockets_git.bb b/recipes-qt/qt5/qtwebsockets_git.bb
index 087ce8ca..d6acaa6e 100644
--- a/recipes-qt/qt5/qtwebsockets_git.bb
+++ b/recipes-qt/qt5/qtwebsockets_git.bb
@@ -1,7 +1,7 @@
require qt5.inc
require qt5-git.inc
-LICENSE = "GFDL-1.3 & (GPL-3 | LGPL-3.0)"
+LICENSE = "GFDL-1.3 & (GPL-3 | LGPL-3.0) | The-Qt-Company-Commercial"
LIC_FILES_CHKSUM = " \
file://LICENSE.GPL2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504 \