summaryrefslogtreecommitdiffstats
path: root/clang/lib/AST/CMakeLists.txt
diff options
context:
space:
mode:
authorSean Callanan <scallanan@apple.com>2017-04-11 19:33:35 +0000
committerSean Callanan <scallanan@apple.com>2017-04-11 19:33:35 +0000
commitb7160ca466175d21a01de50894df47f7c4612e67 (patch)
tree28603dd87d598ec66586831ac76790f3dd082f2f /clang/lib/AST/CMakeLists.txt
parent20dd36a48a76bb4227e19ad5da26066db5a466fa (diff)
[clang-import-test] Lookup inside contexts
clang-import-test has until now been only able to report top-level Decls. This is clearly insufficient; we should be able to look inside structs and namespaces also. This patch adds new test cases for a variety of lookups inside existing ASTContexts, and adds the functionality necessar to make most of these testcases work. (One testcase is known to fail because of ASTImporter limitations when importing templates; I'll look into that separately.) This patch also separates the core functionality out into ExternalASTMerger, an interface that allows clients like LLDB to make use of it. clang-import-test now only has the machinery necessary to set up the tests. Differential revision: https://reviews.llvm.org/D30435 llvm-svn: 299976
Diffstat (limited to 'clang/lib/AST/CMakeLists.txt')
-rw-r--r--clang/lib/AST/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/clang/lib/AST/CMakeLists.txt b/clang/lib/AST/CMakeLists.txt
index 2e98f524da83..13bf352c2f21 100644
--- a/clang/lib/AST/CMakeLists.txt
+++ b/clang/lib/AST/CMakeLists.txt
@@ -31,6 +31,7 @@ add_clang_library(clangAST
ExprConstant.cpp
ExprCXX.cpp
ExprObjC.cpp
+ ExternalASTMerger.cpp
ExternalASTSource.cpp
InheritViz.cpp
ItaniumCXXABI.cpp