summaryrefslogtreecommitdiffstats
path: root/clang/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorManuel Klimek <klimek@google.com>2012-07-06 05:48:52 +0000
committerManuel Klimek <klimek@google.com>2012-07-06 05:48:52 +0000
commit04616e47769af372649ec2c16e89a2fbc1ddce8b (patch)
treee98bd8afbde2e8fb332a727f07d1544bfb6bebd3 /clang/lib/CMakeLists.txt
parent5e6e6264f43b03c0c83610245b79da1f998551ee (diff)
Adds the AST Matcher library, which provides a in-C++ DSL to express
matches on interesting parts of the AST, and callback mechanisms to act on them. llvm-svn: 159805
Diffstat (limited to 'clang/lib/CMakeLists.txt')
-rw-r--r--clang/lib/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/clang/lib/CMakeLists.txt b/clang/lib/CMakeLists.txt
index dfb9d61ff539..206c22818b3c 100644
--- a/clang/lib/CMakeLists.txt
+++ b/clang/lib/CMakeLists.txt
@@ -3,6 +3,7 @@ add_subdirectory(Basic)
add_subdirectory(Lex)
add_subdirectory(Parse)
add_subdirectory(AST)
+add_subdirectory(ASTMatchers)
add_subdirectory(Sema)
add_subdirectory(CodeGen)
add_subdirectory(Analysis)