summaryrefslogtreecommitdiffstats
path: root/clang/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Collingbourne <peter@pcc.me.uk>2010-08-24 00:31:22 +0000
committerPeter Collingbourne <peter@pcc.me.uk>2010-08-24 00:31:22 +0000
commit85dd0bd18d5c5f59207d993f35bdcc9033d3bbf7 (patch)
treef57355baeee64b24382fd17dec53f2ce18d2813f /clang/lib/CMakeLists.txt
parent9d4e471cc2a2d2632adf2c0339223341a1a22801 (diff)
Move ExecuteCompilerInvocation to a new library FrontendTool
r110903 introduced a dependency from Frontend to every library that declared an Action by introducing Action references that previously resided in the driver in the file ExecuteCompilerInvocation.cpp. This patch moves ExecuteCompilerInvocation to a new library named FrontendTool which is intended to bear these dependencies. llvm-svn: 111873
Diffstat (limited to 'clang/lib/CMakeLists.txt')
-rw-r--r--clang/lib/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/clang/lib/CMakeLists.txt b/clang/lib/CMakeLists.txt
index 8ecfcbea29b2..bd5e342e028f 100644
--- a/clang/lib/CMakeLists.txt
+++ b/clang/lib/CMakeLists.txt
@@ -10,5 +10,6 @@ add_subdirectory(Rewrite)
add_subdirectory(Driver)
add_subdirectory(Serialization)
add_subdirectory(Frontend)
+add_subdirectory(FrontendTool)
add_subdirectory(Index)
add_subdirectory(Checker)