summaryrefslogtreecommitdiffstats
path: root/clang/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorJordan Rose <jordan_rose@apple.com>2013-08-22 15:50:02 +0000
committerJordan Rose <jordan_rose@apple.com>2013-08-22 15:50:02 +0000
commita1e4b122236924504007522f2ea9e00a18a2142f (patch)
tree6a1d2712ff431700de0dbe8279b3b9b14c3cd98d /clang/lib/CMakeLists.txt
parent23fc6f34c379f5ba20dcb9b07c46b04ec72c0f0a (diff)
Fix dependencies now that the ARC migrator depends on the static analyzer.
Thanks for pointing this out, Stephen. I think this is right now -- I attempted to try all four valid combinations with both the autoconf and CMake builds. See also LLVM changes to the configure script. llvm-svn: 189027
Diffstat (limited to 'clang/lib/CMakeLists.txt')
-rw-r--r--clang/lib/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/clang/lib/CMakeLists.txt b/clang/lib/CMakeLists.txt
index 6df8ebcce655..7bb65e923e2c 100644
--- a/clang/lib/CMakeLists.txt
+++ b/clang/lib/CMakeLists.txt
@@ -11,7 +11,9 @@ add_subdirectory(CodeGen)
add_subdirectory(Analysis)
add_subdirectory(Edit)
add_subdirectory(Rewrite)
-add_subdirectory(ARCMigrate)
+if(CLANG_ENABLE_ARCMT)
+ add_subdirectory(ARCMigrate)
+endif()
add_subdirectory(Driver)
add_subdirectory(Serialization)
add_subdirectory(Frontend)