summaryrefslogtreecommitdiffstats
path: root/clang/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorManuel Klimek <klimek@google.com>2011-04-21 18:37:41 +0000
committerManuel Klimek <klimek@google.com>2011-04-21 18:37:41 +0000
commitd861e8b7bebcb7a36a158955a795b36128033c66 (patch)
tree9931f3f4ac398f2ebdaf51b6785ba07986c9288c /clang/lib/CMakeLists.txt
parentc3dc4867523f395709b95da2a3d79cf30f5c6a6a (diff)
Adds a function to run FrontendActions over in-memory code. This is
the first step towards a standalone Clang tool infrastructure. The plan is to make it easy to build command line tools that run over the AST of source files in a project outside of the build system. llvm-svn: 129924
Diffstat (limited to 'clang/lib/CMakeLists.txt')
-rw-r--r--clang/lib/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/clang/lib/CMakeLists.txt b/clang/lib/CMakeLists.txt
index b4574344bc5f..0943e2b1c785 100644
--- a/clang/lib/CMakeLists.txt
+++ b/clang/lib/CMakeLists.txt
@@ -13,3 +13,4 @@ add_subdirectory(Frontend)
add_subdirectory(FrontendTool)
add_subdirectory(Index)
add_subdirectory(StaticAnalyzer)
+add_subdirectory(Tooling)