summaryrefslogtreecommitdiffstats
path: root/clang/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorGabor Horvath <xazax.hun@gmail.com>2017-09-22 11:11:01 +0000
committerGabor Horvath <xazax.hun@gmail.com>2017-09-22 11:11:01 +0000
commite350b0a19629c4cce87f28913b3137f4c7015de3 (patch)
treea4f0983ee67dfce83756b62c7036ae105ca9cb11 /clang/lib/CMakeLists.txt
parentd0d900d8503e7574d031cdebd4acb91267effee9 (diff)
Add Cross Translation Unit support library
This patch introduces a class that can help to build tools that require cross translation unit facilities. This class allows function definitions to be loaded from external AST files based on an index. In order to use this functionality an index is required. The index format is a flat text file but it might be replaced with a different solution in the near future. USRs are used as names to look up the functions definitions. This class also does caching to avoid redundant loading of AST files. Right now only function defnitions can be loaded using this API because this is what the in progress cross translation unit feature of the Static Analyzer requires. In to future this might be extended to classes, types etc. Differential Revision: https://reviews.llvm.org/D34512 llvm-svn: 313975
Diffstat (limited to 'clang/lib/CMakeLists.txt')
-rw-r--r--clang/lib/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/clang/lib/CMakeLists.txt b/clang/lib/CMakeLists.txt
index dfd819a407e9..b3fa93555b07 100644
--- a/clang/lib/CMakeLists.txt
+++ b/clang/lib/CMakeLists.txt
@@ -4,6 +4,7 @@ add_subdirectory(Lex)
add_subdirectory(Parse)
add_subdirectory(AST)
add_subdirectory(ASTMatchers)
+add_subdirectory(CrossTU)
add_subdirectory(Sema)
add_subdirectory(CodeGen)
add_subdirectory(Analysis)