summaryrefslogtreecommitdiffstats
path: root/clang/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Jasper <djasper@google.com>2012-12-03 18:12:45 +0000
committerDaniel Jasper <djasper@google.com>2012-12-03 18:12:45 +0000
commitf79351157959adde9a65d99075590a9db613a77b (patch)
treef2771983d8664d33384dcf9bdfa2167eefdde599 /clang/lib/CMakeLists.txt
parent2ed1c0922c18f4e00d43e5fdae4565f9b40f94db (diff)
Initial version of formatting library.
This formatting library will be used by a stand-alone clang-format tool and can also be used when writing other refactorings. Manuel's original design document: https://docs.google.com/a/google.com/document/d/1gpckL2U_6QuU9YW2L1ABsc4Fcogn5UngKk7fE5dDOoA/edit The library can already successfully format itself. Review: http://llvm-reviews.chandlerc.com/D80 llvm-svn: 169137
Diffstat (limited to 'clang/lib/CMakeLists.txt')
-rw-r--r--clang/lib/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/clang/lib/CMakeLists.txt b/clang/lib/CMakeLists.txt
index 206c22818b3c..053320ced1d0 100644
--- a/clang/lib/CMakeLists.txt
+++ b/clang/lib/CMakeLists.txt
@@ -16,3 +16,4 @@ add_subdirectory(Frontend)
add_subdirectory(FrontendTool)
add_subdirectory(Tooling)
add_subdirectory(StaticAnalyzer)
+add_subdirectory(Format)