summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Jasper <djasper@google.com>2013-07-29 08:19:24 +0000
committerDaniel Jasper <djasper@google.com>2013-07-29 08:19:24 +0000
commit62bb8df359f9552f40a673671d9ee0c918b0f002 (patch)
tree30a844bd1ef568fd3270aaba0f9fe2820131a544 /CMakeLists.txt
parent1245ea23fab19e891bf11c41177409ae30235e1e (diff)
Initial architecture for clang-tidy.
This is the first version of a possible clang-tidy architecture. The purpose of clang-tidy is to detect errors in adhering to common coding patterns, e.g. described in the LLVM Coding Standards. This is still heavily in flux. Review: http://llvm-reviews.chandlerc.com/D884 git-svn-id: https://llvm.org/svn/llvm-project/clang-tools-extra/trunk@187345 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6a4d3793..fdd2426f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,6 +2,7 @@ add_subdirectory(remove-cstr-calls)
add_subdirectory(tool-template)
add_subdirectory(cpp11-migrate)
add_subdirectory(modularize)
+add_subdirectory(clang-tidy)
# Add the common testsuite after all the tools.
add_subdirectory(test)