summaryrefslogtreecommitdiffstats
path: root/clang-include-fixer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'clang-include-fixer/CMakeLists.txt')
-rw-r--r--clang-include-fixer/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/clang-include-fixer/CMakeLists.txt b/clang-include-fixer/CMakeLists.txt
new file mode 100644
index 00000000..f27f7403
--- /dev/null
+++ b/clang-include-fixer/CMakeLists.txt
@@ -0,0 +1,29 @@
+set(LLVM_LINK_COMPONENTS
+ support
+ )
+
+add_clang_library(clangIncludeFixer
+ IncludeFixer.cpp
+ IncludeFixerContext.cpp
+ InMemorySymbolIndex.cpp
+ FuzzySymbolIndex.cpp
+ SymbolIndexManager.cpp
+ YamlSymbolIndex.cpp
+
+ LINK_LIBS
+ clangAST
+ clangBasic
+ clangFormat
+ clangFrontend
+ clangLex
+ clangParse
+ clangSema
+ clangSerialization
+ clangTooling
+ clangToolingCore
+ findAllSymbols
+ )
+
+add_subdirectory(plugin)
+add_subdirectory(tool)
+add_subdirectory(find-all-symbols)