summaryrefslogtreecommitdiffstats
path: root/clang-include-fixer/find-all-symbols/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'clang-include-fixer/find-all-symbols/CMakeLists.txt')
-rw-r--r--clang-include-fixer/find-all-symbols/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/clang-include-fixer/find-all-symbols/CMakeLists.txt b/clang-include-fixer/find-all-symbols/CMakeLists.txt
new file mode 100644
index 00000000..c5fe19bf
--- /dev/null
+++ b/clang-include-fixer/find-all-symbols/CMakeLists.txt
@@ -0,0 +1,24 @@
+set(LLVM_LINK_COMPONENTS
+ Support
+ )
+
+add_clang_library(findAllSymbols
+ FindAllSymbols.cpp
+ FindAllSymbolsAction.cpp
+ FindAllMacros.cpp
+ HeaderMapCollector.cpp
+ PathConfig.cpp
+ PragmaCommentHandler.cpp
+ STLPostfixHeaderMap.cpp
+ SymbolInfo.cpp
+
+ LINK_LIBS
+ clangAST
+ clangASTMatchers
+ clangBasic
+ clangFrontend
+ clangLex
+ clangTooling
+ )
+
+add_subdirectory(tool)