summaryrefslogtreecommitdiffstats
path: root/clang-include-fixer/find-all-symbols/tool/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'clang-include-fixer/find-all-symbols/tool/CMakeLists.txt')
-rw-r--r--clang-include-fixer/find-all-symbols/tool/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/clang-include-fixer/find-all-symbols/tool/CMakeLists.txt b/clang-include-fixer/find-all-symbols/tool/CMakeLists.txt
new file mode 100644
index 00000000..64278ad1
--- /dev/null
+++ b/clang-include-fixer/find-all-symbols/tool/CMakeLists.txt
@@ -0,0 +1,24 @@
+include_directories(${CMAKE_CURRENT_SOURCE_DIR}/..)
+
+add_clang_executable(find-all-symbols
+ FindAllSymbolsMain.cpp
+ )
+
+target_link_libraries(find-all-symbols
+ PRIVATE
+ clangAST
+ clangASTMatchers
+ clangBasic
+ clangFrontend
+ clangLex
+ clangSerialization
+ clangTooling
+ findAllSymbols
+ )
+
+install(TARGETS find-all-symbols
+ RUNTIME DESTINATION bin)
+
+install(PROGRAMS run-find-all-symbols.py
+ DESTINATION share/clang
+ COMPONENT find-all-symbols)