summaryrefslogtreecommitdiffstats
path: root/clangd/refactor/tweaks/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'clangd/refactor/tweaks/CMakeLists.txt')
-rw-r--r--clangd/refactor/tweaks/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/clangd/refactor/tweaks/CMakeLists.txt b/clangd/refactor/tweaks/CMakeLists.txt
new file mode 100644
index 00000000..35528d87
--- /dev/null
+++ b/clangd/refactor/tweaks/CMakeLists.txt
@@ -0,0 +1,21 @@
+include_directories(${CMAKE_CURRENT_SOURCE_DIR}/../..)
+
+set(LLVM_LINK_COMPONENTS
+ support
+ )
+
+# A target containing all code tweaks (i.e. mini-refactorings) provided by
+# clangd.
+# Built as an object library to make sure the linker does not remove global
+# constructors that register individual tweaks in a global registry.
+# To enable these tweaks in executables or shared libraries, add
+# $<TARGET_OBJECTS:obj.clangDaemonTweaks> to a list of sources, see
+# clangd/tool/CMakeLists.txt for an example.
+add_clang_library(clangDaemonTweaks OBJECT
+ SwapIfBranches.cpp
+
+ LINK_LIBS
+ clangAST
+ clangDaemon
+ clangToolingCore
+ )