summaryrefslogtreecommitdiffstats
path: root/clangd/unittests/xpc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'clangd/unittests/xpc/CMakeLists.txt')
-rw-r--r--clangd/unittests/xpc/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/clangd/unittests/xpc/CMakeLists.txt b/clangd/unittests/xpc/CMakeLists.txt
new file mode 100644
index 00000000..21a1667b
--- /dev/null
+++ b/clangd/unittests/xpc/CMakeLists.txt
@@ -0,0 +1,22 @@
+set(LLVM_LINK_COMPONENTS
+ support
+ )
+
+get_filename_component(CLANGD_SOURCE_DIR
+ ${CMAKE_CURRENT_SOURCE_DIR}/../../clangd REALPATH)
+include_directories(
+ ${CLANGD_SOURCE_DIR}
+ )
+
+add_custom_target(ClangdXpcUnitTests)
+add_unittest(ClangdXpcUnitTests ClangdXpcTests
+ ConversionTests.cpp
+ )
+
+target_link_libraries(ClangdXpcTests
+ PRIVATE
+ clangdXpcJsonConversions
+ clangDaemon
+ LLVMSupport
+ LLVMTestingSupport
+ )