summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt52
1 files changed, 13 insertions, 39 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index adeb0368..a2cedeaa 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -15,18 +15,20 @@ endif ()
string(REPLACE ${CMAKE_CFG_INTDIR} ${LLVM_BUILD_MODE} CLANG_TOOLS_DIR ${LLVM_RUNTIME_OUTPUT_INTDIR})
-llvm_canonicalize_cmake_booleans(
- CLANG_ENABLE_STATIC_ANALYZER
- CLANGD_BUILD_XPC_SUPPORT)
+llvm_canonicalize_cmake_booleans(CLANG_ENABLE_STATIC_ANALYZER)
configure_lit_site_cfg(
- ${CMAKE_CURRENT_SOURCE_DIR}/lit.site.cfg.in
- ${CMAKE_CURRENT_BINARY_DIR}/lit.site.cfg
+ ${CMAKE_CURRENT_SOURCE_DIR}/lit.site.cfg.py.in
+ ${CMAKE_CURRENT_BINARY_DIR}/lit.site.cfg.py
+ MAIN_CONFIG
+ ${CMAKE_CURRENT_SOURCE_DIR}/lit.cfg.py
)
configure_lit_site_cfg(
- ${CMAKE_CURRENT_SOURCE_DIR}/Unit/lit.site.cfg.in
- ${CMAKE_CURRENT_BINARY_DIR}/Unit/lit.site.cfg
+ ${CMAKE_CURRENT_SOURCE_DIR}/Unit/lit.site.cfg.py.in
+ ${CMAKE_CURRENT_BINARY_DIR}/Unit/lit.site.cfg.py
+ MAIN_CONFIG
+ ${CMAKE_CURRENT_SOURCE_DIR}/Unit/lit.cfg.py
)
option(CLANG_TOOLS_TEST_USE_VG "Run Clang tools' tests under Valgrind" OFF)
@@ -59,39 +61,23 @@ set(CLANG_TOOLS_TEST_DEPS
# For the clang-tidy libclang integration test.
c-index-test
# clang-tidy tests require it.
- clang-headers
+ clang-resource-headers
clang-tidy
+ # Clang-tidy tests need clang for building modules.
+ clang
)
-if(CLANGD_BUILD_XPC_SUPPORT)
- list(APPEND CLANG_TOOLS_TEST_DEPS clangd-xpc-test-client)
-endif()
-
-set(CLANGD_TEST_DEPS
- clangd
- ClangdTests
- # clangd-related tools which don't have tests, add them to the test to make
- # sure we don't introduce new changes that break their compilations.
- clangd-indexer
- dexp
- )
-
# Add lit test dependencies.
set(LLVM_UTILS_DEPS
FileCheck count not
)
foreach(dep ${LLVM_UTILS_DEPS})
if(TARGET ${dep})
- list(APPEND CLANGD_TEST_DEPS ${dep})
+ list(APPEND CLANG_TOOLS_TEST_DEPS ${dep})
endif()
endforeach()
-foreach(clangd_dep ${CLANGD_TEST_DEPS})
- list(APPEND CLANG_TOOLS_TEST_DEPS
- ${clangd_dep})
-endforeach()
-
add_lit_testsuite(check-clang-tools "Running the Clang extra tools' regression tests"
${CMAKE_CURRENT_BINARY_DIR}
DEPENDS ${CLANG_TOOLS_TEST_DEPS}
@@ -99,15 +85,3 @@ add_lit_testsuite(check-clang-tools "Running the Clang extra tools' regression t
)
set_target_properties(check-clang-tools PROPERTIES FOLDER "Clang extra tools' tests")
-
-# Setup an individual test for building and testing clangd-only stuff.
-# Note: all clangd tests have been covered in check-clang-tools, this is a
-# convenient target for clangd developers.
-# Exclude check-clangd from check-all.
-set(EXCLUDE_FROM_ALL ON)
-add_lit_testsuite(check-clangd "Running the Clangd regression tests"
- ${CMAKE_CURRENT_BINARY_DIR}/Unit/clangd;${CMAKE_CURRENT_BINARY_DIR}/clangd
- DEPENDS ${CLANGD_TEST_DEPS}
-)
-set_target_properties(check-clangd PROPERTIES FOLDER "Clangd tests")
-set(EXCLUDE_FROM_ALL OFF)