summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNAKAMURA Takumi <geek4civic@gmail.com>2014-02-23 12:53:45 +0000
committerNAKAMURA Takumi <geek4civic@gmail.com>2014-02-23 12:53:45 +0000
commit1c0d41bb18c3d94eb3c9ecb4384948a626c8e162 (patch)
tree4cfcf44837e7d5c9d91a49cca564a1128a8fefc2 /CMakeLists.txt
parentb5595cd0e48d97c90b89364b60c8ba1672daba74 (diff)
[CMake] Deprecate clang_tablegen(DEPENDS).
git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@201971 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 38b14b5a0f..d863201bec 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -255,7 +255,7 @@ function(clang_tablegen)
# executing the custom command depending on output-file. It is
# possible to list more files to depend after DEPENDS.
- cmake_parse_arguments(CTG "" "SOURCE;TARGET" "DEPENDS" ${ARGN})
+ cmake_parse_arguments(CTG "" "SOURCE;TARGET" "" ${ARGN})
if( NOT CTG_SOURCE )
message(FATAL_ERROR "SOURCE source-file required by clang_tablegen")
@@ -266,7 +266,7 @@ function(clang_tablegen)
list(GET CTG_UNPARSED_ARGUMENTS 0 output_file)
if( CTG_TARGET )
- add_custom_target( ${CTG_TARGET} DEPENDS ${output_file} ${CTG_DEPENDS} )
+ add_custom_target(${CTG_TARGET} DEPENDS ${output_file})
set_target_properties( ${CTG_TARGET} PROPERTIES FOLDER "Clang tablegenning")
set_property(GLOBAL APPEND PROPERTY CLANG_TABLEGEN_TARGETS ${CTG_TARGET})
endif()