summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNAKAMURA Takumi <geek4civic@gmail.com>2014-01-28 09:47:12 +0000
committerNAKAMURA Takumi <geek4civic@gmail.com>2014-01-28 09:47:12 +0000
commit9ac60551645be7a3c5f9b702159052f2f1a5b26a (patch)
treed7de4d208418b4614c268597a96ad02c20547fbd /CMakeLists.txt
parente4934a209ac48fa5748574a5743567568730a504 (diff)
[CMake] Apply llvm_update_compile_flags() to add_clang_library().
git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@200302 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c4f61df191..3c2a0fc552 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -307,6 +307,7 @@ macro(add_clang_library name)
set(libkind)
endif()
add_library( ${name} ${libkind} ${srcs} )
+ llvm_update_compile_flags(${name} ${ALL_FILES})
add_dead_strip( ${name} )
set_output_directory(${name} ${LLVM_RUNTIME_OUTPUT_INTDIR} ${LLVM_LIBRARY_OUTPUT_INTDIR})
if( LLVM_COMMON_DEPENDS )