summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNAKAMURA Takumi <geek4civic@gmail.com>2014-02-10 10:51:09 +0000
committerNAKAMURA Takumi <geek4civic@gmail.com>2014-02-10 10:51:09 +0000
commita0b8dd6f10dc239d47fdee373c9700a4e4e76064 (patch)
tree2b8cff6dae6000ea66fe2b2971f2a0cd32eb497f /CMakeLists.txt
parent81881ac900ad705f9ed3e8f43e7ff329b80d14ea (diff)
Fix Clang install rules to not set permissions on include/
The CMake install(DIRECTORY) command documents that it sets permissions on directories it is asked to install. Since the <prefix>/include directory may not be exclusive to the LLVM/Clang installation, we should not ask CMake to manage permissions of that directory for us. Instead, give only our own include/clang and include/clang-c subdirectories to the install(DIRECTORY) command. Fixes PR4500. Patch by Brad King. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@201076 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cfe32a0684..cf481bf816 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -336,7 +336,7 @@ include_directories(BEFORE
)
if (NOT LLVM_INSTALL_TOOLCHAIN_ONLY)
- install(DIRECTORY include/
+ install(DIRECTORY include/clang include/clang-c
DESTINATION include
FILES_MATCHING
PATTERN "*.def"
@@ -345,7 +345,7 @@ if (NOT LLVM_INSTALL_TOOLCHAIN_ONLY)
PATTERN ".svn" EXCLUDE
)
- install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/include/
+ install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/include/clang
DESTINATION include
FILES_MATCHING
PATTERN "CMakeFiles" EXCLUDE