summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNAKAMURA Takumi <geek4civic@gmail.com>2014-01-23 15:33:35 +0000
committerNAKAMURA Takumi <geek4civic@gmail.com>2014-01-23 15:33:35 +0000
commitb54f0d24abdd61d13da2c10c0c18428c76dcd193 (patch)
tree871d8a58096c3f6981335c4a623afc93d66cb35c /CMakeLists.txt
parent2cd3061bceb9a59884ec687b715a1b04ac83f8be (diff)
[CMake] Migrate LLVMParseArguments to CMakeParseArguments.
git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@199901 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3851f6a6a2..efeda29500 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -243,7 +243,7 @@ configure_file(
${CLANG_SOURCE_DIR}/include/clang/Config/config.h.cmake
${CLANG_BINARY_DIR}/include/clang/Config/config.h)
-include(LLVMParseArguments)
+include(CMakeParseArguments)
function(clang_tablegen)
# Syntax:
@@ -258,16 +258,16 @@ function(clang_tablegen)
# executing the custom command depending on output-file. It is
# possible to list more files to depend after DEPENDS.
- parse_arguments( CTG "SOURCE;TARGET;DEPENDS" "" ${ARGN} )
+ cmake_parse_arguments(CTG "" "SOURCE;TARGET" "DEPENDS" ${ARGN})
if( NOT CTG_SOURCE )
message(FATAL_ERROR "SOURCE source-file required by clang_tablegen")
endif()
set( LLVM_TARGET_DEFINITIONS ${CTG_SOURCE} )
- tablegen( CLANG ${CTG_DEFAULT_ARGS} )
+ tablegen(CLANG ${CTG_UNPARSED_ARGUMENTS})
- list( GET CTG_DEFAULT_ARGS 0 output_file )
+ list(GET CTG_UNPARSED_ARGUMENTS 0 output_file)
if( CTG_TARGET )
add_custom_target( ${CTG_TARGET} DEPENDS ${output_file} ${CTG_DEPENDS} )
set_target_properties( ${CTG_TARGET} PROPERTIES FOLDER "Clang tablegenning")