summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNAKAMURA Takumi <geek4civic@gmail.com>2014-02-04 12:26:40 +0000
committerNAKAMURA Takumi <geek4civic@gmail.com>2014-02-04 12:26:40 +0000
commitbb52a574ed687223737b8e4747fd2ec30047f45f (patch)
tree994abfefda752654217da2f5f8ebce62280e11e3 /CMakeLists.txt
parent661bb397eb18942cb53ca14399065ad3489bf40c (diff)
[CMake] add_clang_library(): Honor STATIC.
git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@200759 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8028904a4c..8e93505b6f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -304,6 +304,8 @@ macro(add_clang_library name)
set(libkind MODULE)
elseif (ARG_SHARED)
set(libkind SHARED)
+ elseif(ARG_STATIC)
+ set(libkind STATIC)
else()
set(libkind)
endif()