summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlp Toker <alp@nuanti.com>2014-07-14 23:10:07 +0000
committerAlp Toker <alp@nuanti.com>2014-07-14 23:10:07 +0000
commitd3a379f1f5d475ca5e3d757658362c57da39f194 (patch)
tree5d9d81150167917ed7584a42dcadfb45ce2d1533 /CMakeLists.txt
parent972dfa6156c05c418df4c9520d36b727b3639097 (diff)
Revert "Move clang feature flags settings out of LLVM core and into cfe"
Prospectively revert to get one of the many build configurations back working (presumably the side-by-side+modular CMake config). This reverts commit r212997. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@213008 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 0 insertions, 17 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b93a78ec01..28f4e3fb81 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -385,25 +385,8 @@ install(DIRECTORY include/clang-c
add_definitions( -D_GNU_SOURCE )
option(CLANG_ENABLE_ARCMT "Build ARCMT." ON)
-if (CLANG_ENABLE_ARCMT)
- set(ENABLE_CLANG_ARCMT "1")
-else()
- set(ENABLE_CLANG_ARCMT "0")
-endif()
-
option(CLANG_ENABLE_REWRITER "Build rewriter." ON)
-if (CLANG_ENABLE_REWRITER)
- set(ENABLE_CLANG_REWRITER "1")
-else()
- set(ENABLE_CLANG_REWRITER "0")
-endif()
-
option(CLANG_ENABLE_STATIC_ANALYZER "Build static analyzer." ON)
-if (CLANG_ENABLE_STATIC_ANALYZER)
- set(ENABLE_CLANG_STATIC_ANALYZER "1")
-else()
- set(ENABLE_CLANG_STATIC_ANALYZER "0")
-endif()
if (NOT CLANG_ENABLE_REWRITER AND CLANG_ENABLE_ARCMT)
message(FATAL_ERROR "Cannot disable rewriter while enabling ARCMT")