summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael J. Spencer <bigcheesegs@gmail.com>2010-09-11 02:13:48 +0000
committerMichael J. Spencer <bigcheesegs@gmail.com>2010-09-11 02:13:48 +0000
commit28709c14ac027d505eff42f9b7a48f415241fd24 (patch)
tree74164b1351e61ee71caa8cf7c5762e2a5e9062ad /CMakeLists.txt
parentc5904b40c3d76b612fb09c6d2717f646a0af6670 (diff)
CMake: Fix mingw32 build.
git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@113677 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fdc7755de8..5577e318c2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -88,13 +88,15 @@ macro(add_clang_library name)
if( LLVM_LINK_COMPONENTS )
llvm_config(${name} ${LLVM_LINK_COMPONENTS})
endif( LLVM_LINK_COMPONENTS )
- get_system_libs(llvm_system_libs)
- if( llvm_system_libs )
- target_link_libraries(${name} ${llvm_system_libs})
- endif( llvm_system_libs )
if (LLVM_COMMON_LIBS)
target_link_libraries(${name} ${LLVM_COMMON_LIBS})
endif()
+ if( NOT MINGW )
+ get_system_libs(llvm_system_libs)
+ if( llvm_system_libs )
+ target_link_libraries(${name} ${llvm_system_libs})
+ endif()
+ endif()
add_dependencies(${name} ClangDiagnosticCommon)
if(MSVC)
get_target_property(cflag ${name} COMPILE_FLAGS)