summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Dunbar <daniel@zuster.org>2011-02-18 22:55:32 +0000
committerDaniel Dunbar <daniel@zuster.org>2011-02-18 22:55:32 +0000
commit299696c8c92570fc6c2cb4d861c2ca07885fa3ed (patch)
treeb96a30dc39fb861391b332086de57b2c0fe87b7e /CMakeLists.txt
parent2fdf79ff5e2fdc5b37b4c15381f986894ba87266 (diff)
More correct fix for CMake breakage I was seeing, my buildbots use
LLVM_INCLUDE_TESTS:=OFF, which may no longer be necessary for all I know. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@125985 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 63b721354e..0d923b91e1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -215,7 +215,9 @@ add_subdirectory(tools)
add_subdirectory(runtime)
# TODO: docs.
+if( LLVM_INCLUDE_TESTS )
add_subdirectory(test)
+endif()
# FIXME: unittests require gtest.
if( NOT CLANG_BUILT_STANDALONE )