summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2010-10-15 00:16:22 +0000
committerOscar Fuentes <ofv@wanadoo.es>2010-10-15 00:16:22 +0000
commit827c573881a2728d271f75aaa74054aea6a4a418 (patch)
tree8c8612bcdec6c727f67710a014da15851c519974 /CMakeLists.txt
parentc1028f45ea061455b144ab42d0311aba5838c29c (diff)
Copied some flags from the Makefile build to the list of GCC flags.
This removes a lot of warnings. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@116545 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 854174cd2b..7f6e811414 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -49,7 +49,7 @@ configure_file(
if (CMAKE_COMPILER_IS_GNUCXX)
# FIXME: Turn off exceptions, RTTI:
# -fno-exceptions -fno-rtti
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fno-common -Woverloaded-virtual -pedantic -Wno-long-long -Wall -W -Wno-unused-parameter -Wwrite-strings")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fno-common -Woverloaded-virtual -Wcast-qual -fno-strict-aliasing -pedantic -Wno-long-long -Wall -W -Wno-unused-parameter -Wwrite-strings")
endif ()
if (APPLE)