summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChandler Carruth <chandlerc@gmail.com>2011-06-08 10:13:14 +0000
committerChandler Carruth <chandlerc@gmail.com>2011-06-08 10:13:14 +0000
commit8afdd56babf69cd8e3b45d0baff0d4fc20d088a0 (patch)
tree52ad89f166d4d7ee05938592a6c54485cf9a1a21 /CMakeLists.txt
parent002333f8b2cf1a8614e532f6ce366b21af85142c (diff)
hack in my new variables for GCC
git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@132743 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index aa89823e76..dd33f814c3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -54,6 +54,18 @@ endif()
set(CLANG_RESOURCE_DIR "" CACHE STRING
"Relative directory from the Clang binary to its resource files.")
+set(CLANG_GCC_INSTALL_ROOT "" CACHE STRING
+ "The GCC install root to use for headers and libraries.")
+
+set(CLANG_GCC_LIB_DIR "/lib/gcc" CACHE STRING
+ "The directory relative to the install root for GCC libraries.")
+
+set(CLANG_GCC_ARCH "" CACHE STRING
+ "The architecture string of the GCC installation.")
+
+set(CLANG_GCC_VERSION "" CACHE STRING
+ "The version of the GCC installation.")
+
set(C_INCLUDE_DIRS "" CACHE STRING
"Colon separated list of directories clang will search for headers.")