summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTed Kremenek <kremenek@apple.com>2011-02-10 01:03:09 +0000
committerTed Kremenek <kremenek@apple.com>2011-02-10 01:03:09 +0000
commitb26bd7426dd102273be190bf6fb13f7533838154 (patch)
treeaa4315a6bf99c34c74498ef5fd65520f45bc630b /CMakeLists.txt
parent9b663716449b618ba0390b1dbebc54fa8e971124 (diff)
Add hack to CMakeLists.txt so that StaticAnalyzer libraries find their corresponding headers.
This is a hack because we really should only search in the 'include/clang/StaticAnalyzer' directory if we are in 'lib/StaticAnalyzer'. My CMake knowledge is limited, so I appeal to anyone with more expertise. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@125252 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f7989bc1fe..4189739521 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -124,6 +124,9 @@ macro(add_clang_library name)
string( REGEX MATCHALL "/[^/]+" split_path ${CMAKE_CURRENT_SOURCE_DIR})
list( GET split_path -1 dir)
file( GLOB_RECURSE headers
+ ../../../include/clang/StaticAnalyzer${dir}/*.h
+ ../../../include/clang/StaticAnalyzer${dir}/*.td
+ ../../../include/clang/StaticAnalyzer${dir}/*.def
../../include/clang${dir}/*.h
../../include/clang${dir}/*.td
../../include/clang${dir}/*.def)