summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDouglas Gregor <dgregor@apple.com>2011-02-25 00:12:04 +0000
committerDouglas Gregor <dgregor@apple.com>2011-02-25 00:12:04 +0000
commitfd681570a2ff11380fb4cdb5d84ce5b72c49af55 (patch)
treede187b63047821557f1915169999dc8b987783e8 /CMakeLists.txt
parent116f3640daee424dfcdbe55e80be5a67476be4b0 (diff)
Don't include Clang's unit tests if LLVM's unit tests aren't being built
git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@126455 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 4 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 956a109c7a..afbe13b485 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -246,12 +246,11 @@ add_subdirectory(runtime)
# TODO: docs.
if( LLVM_INCLUDE_TESTS )
-add_subdirectory(test)
-endif()
+ add_subdirectory(test)
-# FIXME: unittests require gtest.
-if( NOT CLANG_BUILT_STANDALONE )
- add_subdirectory(unittests)
+ if( NOT CLANG_BUILT_STANDALONE )
+ add_subdirectory(unittests)
+ endif()
endif()
# Workaround for MSVS10 to avoid the Dialog Hell