summaryrefslogtreecommitdiffstats
path: root/bindings/python/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMichal Gorny <mgorny@gentoo.org>2018-10-11 20:26:55 +0000
committerMichal Gorny <mgorny@gentoo.org>2018-10-11 20:26:55 +0000
commitfcbd643e8f3c210bb467237e971270f8bdb87a01 (patch)
treecc535ad8f20ce5f72fe141dac0bd8370baf19f0b /bindings/python/tests/CMakeLists.txt
parent0bb96efa2d32678d0ac578363b78611074630787 (diff)
[python] [tests] Fix calling tests on Windows
Fix passing arguments to the Python test command to use 'env' builtin CMake command, in order to fix compatibility with Windows. Differential Revision: https://reviews.llvm.org/D53151 git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@344288 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'bindings/python/tests/CMakeLists.txt')
-rw-r--r--bindings/python/tests/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/bindings/python/tests/CMakeLists.txt b/bindings/python/tests/CMakeLists.txt
index b40684f55b..97cd9ba8b6 100644
--- a/bindings/python/tests/CMakeLists.txt
+++ b/bindings/python/tests/CMakeLists.txt
@@ -1,7 +1,9 @@
# Test target to run Python test suite from main build.
add_custom_target(check-clang-python
- COMMAND CLANG_LIBRARY_PATH=$<TARGET_FILE_DIR:libclang> ${PYTHON_EXECUTABLE} -m unittest discover
+ COMMAND ${CMAKE_COMMAND} -E env
+ CLANG_LIBRARY_PATH=$<TARGET_FILE_DIR:libclang>
+ ${PYTHON_EXECUTABLE} -m unittest discover
DEPENDS libclang
WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/..)