summaryrefslogtreecommitdiffstats
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Collingbourne <peter@pcc.me.uk>2012-01-26 03:33:40 +0000
committerPeter Collingbourne <peter@pcc.me.uk>2012-01-26 03:33:40 +0000
commite26198c0980027f0975448709063b56f667ab506 (patch)
treea4a32a64e5c4889b0b03d92cb00f8f179c77b7f9 /examples/CMakeLists.txt
parent516bbd42e62d709013824d6fb8445a0cfda3129a (diff)
Adjust CLANG_BUILD_EXAMPLES to mean whether the examples are built
by default, rather than whether they may be built at all. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@149037 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index 317bc81637..7f4253af2e 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -1,2 +1,6 @@
+if(NOT CLANG_BUILD_EXAMPLES)
+ set(EXCLUDE_FROM_ALL ON)
+endif()
+
add_subdirectory(clang-interpreter)
add_subdirectory(PrintFunctionNames)