summaryrefslogtreecommitdiffstats
path: root/include/clang/Basic/CMakeLists.txt
diff options
context:
space:
mode:
authorAaron Ballman <aaron@aaronballman.com>2014-03-31 13:14:44 +0000
committerAaron Ballman <aaron@aaronballman.com>2014-03-31 13:14:44 +0000
commit3056e7cbc99ea69d655b110e4c6ceb92079522f6 (patch)
tree1e677eb5eed25021e43959c8986a29f54bafb567 /include/clang/Basic/CMakeLists.txt
parent1fe9ec45cdd62dda07c38cf1f6e11a0ed9867847 (diff)
Reapplying r204952 a second time.
Clean up the __has_attribute implementation without modifying its behavior. Replaces the tablegen-driven AttrSpellings.inc, which lived in the lexing layer with AttrHasAttributeImpl.inc, which lives in the basic layer. Updates the preprocessor to call through to this new functionality which can take additional information into account (such as scopes and syntaxes). Expose the ability for parts of the compiler to ask whether an attribute is supported for a given spelling (including scope), syntax, triple and language options. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@205181 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'include/clang/Basic/CMakeLists.txt')
-rw-r--r--include/clang/Basic/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/include/clang/Basic/CMakeLists.txt b/include/clang/Basic/CMakeLists.txt
index 546afd87c9..e4929b5b52 100644
--- a/include/clang/Basic/CMakeLists.txt
+++ b/include/clang/Basic/CMakeLists.txt
@@ -28,6 +28,12 @@ clang_tablegen(AttrList.inc -gen-clang-attr-list
SOURCE Attr.td
TARGET ClangAttrList)
+clang_tablegen(AttrHasAttributeImpl.inc -gen-clang-attr-has-attribute-impl
+ -I ${CMAKE_CURRENT_SOURCE_DIR}/../../
+ SOURCE Attr.td
+ TARGET ClangAttrHasAttributeImpl
+ )
+
# ARM NEON
clang_tablegen(arm_neon.inc -gen-arm-neon-sema
-I ${CMAKE_CURRENT_SOURCE_DIR}/../../