summaryrefslogtreecommitdiffstats
path: root/include/clang/Basic/CMakeLists.txt
diff options
context:
space:
mode:
authorDouglas Gregor <dgregor@apple.com>2011-04-15 22:04:17 +0000
committerDouglas Gregor <dgregor@apple.com>2011-04-15 22:04:17 +0000
commit7d2b8c1fcc2b707be78b09930a7767477822462f (patch)
tree51cf1d026a1422af05b549cda1dec2e352c09cc8 /include/clang/Basic/CMakeLists.txt
parentf9af524b818f7a6f0ed812334482a5d657b2ff5b (diff)
Initial work to improve documentation for Clang's diagnostics, from Matthieu Monrocq
git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@129614 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'include/clang/Basic/CMakeLists.txt')
-rw-r--r--include/clang/Basic/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/clang/Basic/CMakeLists.txt b/include/clang/Basic/CMakeLists.txt
index 19066e4c0e..df49dc6a1c 100644
--- a/include/clang/Basic/CMakeLists.txt
+++ b/include/clang/Basic/CMakeLists.txt
@@ -17,6 +17,10 @@ clang_tablegen(DiagnosticGroups.inc -gen-clang-diag-groups
SOURCE Diagnostic.td
TARGET ClangDiagnosticGroups)
+clang_tablegen(DiagnosticIndexName.inc -gen-clang-diags-index-name
+ SOURCE Diagnostic.td
+ TARGET ClangDiagnosticIndexName)
+
clang_tablegen(AttrList.inc -gen-clang-attr-list
-I ${CMAKE_CURRENT_SOURCE_DIR}/../../
SOURCE Attr.td