summaryrefslogtreecommitdiffstats
path: root/lib/AST/CMakeLists.txt
diff options
context:
space:
mode:
authorCharles Davis <cdavis@mines.edu>2010-08-16 03:33:14 +0000
committerCharles Davis <cdavis@mines.edu>2010-08-16 03:33:14 +0000
commit071cc7deffad608165b1ddd5263e8bf181861520 (patch)
tree6d68d7edf284b5e28784142748d07350ba20d9a3 /lib/AST/CMakeLists.txt
parente701117b21356d3c60133315b5bdd50232ec6cca (diff)
Implement support for member pointers under the Microsoft C++ ABI in the
AST library. This also adds infrastructure for supporting multiple C++ ABIs in the AST. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@111117 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/AST/CMakeLists.txt')
-rw-r--r--lib/AST/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/lib/AST/CMakeLists.txt b/lib/AST/CMakeLists.txt
index 407ed95f3e..b340c0464c 100644
--- a/lib/AST/CMakeLists.txt
+++ b/lib/AST/CMakeLists.txt
@@ -23,6 +23,8 @@ add_clang_library(clangAST
ExprCXX.cpp
FullExpr.cpp
InheritViz.cpp
+ ItaniumCXXABI.cpp
+ MicrosoftCXXABI.cpp
NestedNameSpecifier.cpp
ParentMap.cpp
RecordLayout.cpp